Find the answer to your Linux question:
Results 1 to 7 of 7
For some reason I can't connect to my SSH server from the WAN side. It is working on the LAN side. I forwarded port 22 TCP in the NAT section ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    13

    Can't connect to SSH server from outside.


    For some reason I can't connect to my SSH server from the WAN side.
    It is working on the LAN side.

    I forwarded port 22 TCP in the NAT section of my router.
    this is done correctly -i think- since I openend op HTTP and some ports for my Desert Combat server as well the same way, and these services are accesable from the WAN side.

    As far as the SSH config....I don't know anything about it, I just installed the package in Mandriva Linux, it was accesable from the LAN so I assumed by opening port 22 it would also be accesable from the WAN side.

    I was wrong. Is it some setting in the SSH config (i.e. LAN only by default?)
    Where do I change the config? any help would be nice and very appreciated

  2. #2
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Romania
    Posts
    186
    Maybe your ssh server isn't running... try (as root)
    Code:
    service ssh start
    You can only be young once. But you can always be immature.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    13
    I still have to try that, I'am at my work now.
    But isn't it obvious its running since I CAN connect from another machine within LAN trough SSH?

  4. #4
    Linux Engineer
    Join Date
    Mar 2005
    Location
    Where my hat is
    Posts
    766
    It's possible port 22 is blocked at work. Most IT departments (if they're doing their job right) will block pretty much everything that isn't needed for business.
    Registered Linux user #384279
    Vector Linux SOHO 7

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    13
    Not it's not that, sorry.
    I tried connecting to a free shell host from work (super dimension fortress) and it worked like a breeze.

    I still think it coult be SSH only being availlable for LAN side by default.
    Can anyone tell me if this could be the case?

    of is it something else...?

  6. #6
    Linux Newbie
    Join Date
    Apr 2005
    Location
    Charlottesville, VA
    Posts
    175
    Maybe only your LAN is listed in your hosts.allow file. What are the contents of your /etc/hosts.allow and /etc/hosts.deny files?
    ---sxeraverx---
    Linux without a C Compiler is like eating Spaghetti with your mouth sewn shut. It just doesn't make sense.

  7. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    12
    what does the message say when you try to connect?

    if it says something like "connection refused from remote host"

    then you have to make sure youe /etc/hosts.allow file has the following line
    sshd: 192.168.1.0/255.255.255.0

    where the ip address is put the one from the computer you want to connect from.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •