Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Problems with mounting smbfs filesystem

    Hi. I'm a Linux newbie and my problem is the following:
    I'm using Mandrake 10.1 and I need to mount a Windows share, so I open a console and as root I type:

    mount -t smbfs -o username=my_username //share_path /my_mount_point

    then I enter the password.
    The problem is that I can write there only as root; I need to give also to users the permission to write. How can I do that ?

    [ Excuse me, my English is very bad !!! ]

  2. #2
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Well for a long time I have been using this
    //windowshostname/sharename$ /windows/N smbfs username=myusername,workgroup=WORKGROUP,rw,user,exec,suid,noauto
    in /etc/fstab The user option will allow me to mount it when i'm not root
    ie just mount /windows/N
    and supply password, write access was fine

    That said it seems to be broken recently .... not sure but maybe a kernel update has moved from smbfs to cifs that last bit may be just wibble but I noticed it as I was doing a kernel for my Gentoo box and thought it might be the reason for the SuSE box to break for smbfs mounting, if smbfs works for you then the user option should help
    Registerd Linux user #119296

  3. #3
    Thanks iha... I've tried but it doesn'work.
    However I've found a solution using the command

    smbmount //share_path /mount_point -o username=my_username

    as user...
    but now I've found another problem; I can write, I can modify and delete files, I can create directory with Konqueror but I CAN'T delete any directory neither with Konqueror nor with console if there is Konqueror opened in the mount path.. it said "Device or resource busy"...


  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts