Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Ok, so I recently installed Fedora Core 4 to try and switch over to linux.. I'm very happy so far and see no reason to go back Have a slight ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    26

    Problems with "yum update" :: Missing Dependency


    Ok, so I recently installed Fedora Core 4 to try and switch over to linux..
    I'm very happy so far and see no reason to go back

    Have a slight problem though..
    When I want to update my packages and type 'yum update' into the terminal, I eventually (after it goes trough a whole list of checking things to be updated) get the following error:
    Code:
    --> Running transaction check
    --> Processing Dependency: mplayer = 0:1.0-0.lvn.0.23.pre7.4 for package: mplayer-gui
    --> Finished Dependency Resolution
    Error: Missing Dependency: mplayer = 0:1.0-0.lvn.0.23.pre7.4 is needed by package mplayer-gui
    The error is correct in that way that I have pre7.2 installed..
    However when I chose to update mplayer by using 'yum update mplayer' I got the same error message.

    Excuse me if I said some dumb things, I'm still learning.
    However, is this a known problem and does anyone have any idea about how to fix it?

    I also tried the following (read it on some forum to use this command, can't find where anymore):
    Code:
    yum -d 10 install mplayer mplayer-gui
    It gives me the following error:
    Code:
    Dep Number: 1/1
    mplayer-gui requires: mplayer = 0:1.0-0.lvn.0.23.pre7.4
    --> Processing Dependency: mplayer = 0:1.0-0.lvn.0.23.pre7.4 for package: mplayer-gui
    Calling rpmdb.returnHeaderByTuple on mplayer-gui.i386 0:1.0-0.lvn.0.23.pre7.4
    Requiring package is installed: mplayer-gui - 1.0-0.lvn.0.23.pre7.4.i386
    Resolving for installed requiring package: mplayer-gui - 1.0-0.lvn.0.23.pre7.4.i386
    Resolving for requirement: mplayer = 0:1.0-0.lvn.0.23.pre7.4
    Potential Provider: mplayer.i386 0:1.0-0.16.pre7.2.fc4
    Mode is u for provider of mplayer = 0:1.0-0.lvn.0.23.pre7.4: mplayer.i386 0:1.0-0.16.pre7.2.fc4
    Mode for pkg providing mplayer = 0:1.0-0.lvn.0.23.pre7.4: u
    Cannot find an update path for dep for: mplayer = 0:1.0-0.lvn.0.23.pre7.4
    Searching pkgSack for dep: mplayer
    Potential match for mplayer from mplayer - 1.0-0.16.pre7.2.fc4.i386
    Potential match for mplayer from mplayer - 1.0-0.lvn.0.22.pre7.4.i386
    Potential match for mplayer from mplayer - 1.0-0.lvn.0.23.pre7.4.i386
    Matched mplayer - 1.0-0.lvn.0.23.pre7.4.i386 to require for mplayer
    mplayer - 1.0-0.lvn.0.23.pre7.4.i386 is in providing packages but it is already installed, removing.
    miss = 3
    conf = 0
    CheckDeps = 0
    --> Finished Dependency Resolution
    Dependency Process ending
    Error: Missing Dependency: mplayer = 0:1.0-0.lvn.0.23.pre7.4 is needed by package mplayer-gui

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I know a lot of FC users think it is sacrilege to use anything other than YUM to install and update software, but you might also want to check out apt-get RPM. I use it on all my Fedora boxes, and unlike YUM, it has a nice "GUI" front end called synaptic which easily installs. It has always done a good job for me figuring out dependency problems, so if you can't get this resolved with YUM, you might want to check it out. Good Luck!
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    I agree with Dapper Dan.
    I personally prefere DAG's apt package though
    (do the ones from FresRPMS still use an /etc/apt/souces.list instead of /etc/apt/sources.list.d?)
    see: http://dag.wieers.com/home-made/apt/FAQ.php#B3

  4. #4
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Romania
    Posts
    186
    Try
    Code:
    yum install mplayer
    and after that is completed do
    Code:
    yum install mplayer-gui
    Although I think it should've worked like you tried it too...
    You can only be young once. But you can always be immature.

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    26
    @ sharkyro:
    I tried that, but as I already suspected, those were already installed so it didn't work
    Also tried to update them, didn't work either (not even manually -- under manually I understand double-clicking the RPM, that's as far as my linux experience with installing goes a.t.m., if there's a better way [and no doubt there is] please tell me)

    Got everything updated with 'yum update' now though..
    that is, after doing a yum remove mplayer
    and a yum remove mplayer-gui

    But now, when I try reinstalling mplayer and mplayer-gui, it gives me the following error;
    Code:
    Transaction Check Error:   file /usr/lib/libpostproc.so.0.0.1 conflicts between attempted installs of libpostproc-1.0-0.16.pre7.2.fc4 and ffmpeg-0.4.9-0.lvn.0.17.20050427.4
    @Dapper Dan & jens:
    Thanks, I'll try out apt-get too!
    But I really want this yum problem to be fixed no matter wich one of the two I'll get used to and start using..
    Just because I refuse to give up and really want this thing to get fixed
    In the hope I'll learn something out of it and get more experienced (even if it's just a little) with using linux.

  6. #6
    Linux User
    Join Date
    May 2005
    Posts
    473
    i like apt-get much more, i dont know why, but it just is much easier and yum seems a little buggy

  7. #7
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    Quote Originally Posted by Zhann
    @ sharkyro:
    I tried that, but as I already suspected, those were already installed so it didn't work
    Also tried to update them, didn't work either (not even manually -- under manually I understand double-clicking the RPM, that's as far as my linux experience with installing goes a.t.m., if there's a better way [and no doubt there is] please tell me)

    Got everything updated with 'yum update' now though..
    that is, after doing a yum remove mplayer
    and a yum remove mplayer-gui

    But now, when I try reinstalling mplayer and mplayer-gui, it gives me the following error;
    Code:
    Transaction Check Error:   file /usr/lib/libpostproc.so.0.0.1 conflicts between attempted installs of libpostproc-1.0-0.16.pre7.2.fc4 and ffmpeg-0.4.9-0.lvn.0.17.20050427.4
    @Dapper Dan & jens:
    Thanks, I'll try out apt-get too!
    But I really want this yum problem to be fixed no matter wich one of the two I'll get used to and start using..
    Just because I refuse to give up and really want this thing to get fixed
    In the hope I'll learn something out of it and get more experienced (even if it's just a little) with using linux.
    Looks like you mixed the wrong repos.
    Could you post your yum.conf ?

  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    26
    Quote Originally Posted by jens
    Looks like you mixed the wrong repos.
    Could you post your yum.conf ?
    My yum.conf:
    Code:
    [main]
    cachedir=/var/cache/yum
    debuglevel=2
    logfile=/var/log/yum.log
    pkgpolicy=newest
    distroverpkg=redhat-release
    tolerant=1
    exactarch=1
    retries=20
    obsoletes=1
    gpgcheck=1
    
    # PUT YOUR REPOS HERE OR IN separate files named file.repo
    # in /etc/yum.repos.d
    
    [livna]
    name=Livna.org - Fedora Compatible Packages (stable)
    baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.lvn
    http://livna.cat.pdx.edu/fedora/$releasever/$basearch/yum/RPMS.lvn
    gpgcheck=1
    gpgkey=http://rpm.livna.org/RPM-LIVNA-GPG-KEY-$basearch
    
    [freshrpms]
    name=Fedora Linux $releasever - $basearch - freshrpms
    #baseurl=http://ayo.freshrpms.net/fedora/linux/$releasever/$basearch/freshrpms
    mirrorlist=http://ayo.freshrpms.net/fedora/linux/$releasever/mirrors-freshrpms 
    enabled=1
    gpgcheck=1
    gpgkey=http://freshrpms.net/packages/RPM-GPG-KEY.txt
    thanks for helping me out by the way

  9. #9
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    Yep... you're using incompatible repos.
    You can only mix Livna.org with fedora.us(my advice, don't use either of them).
    Remove Livna and add DAG(you could also add Dries and many more):
    http://dag.wieers.com/home-made/apt/
    Nex try to remove everything from Livna and reinstall it from your new yum.conf(I still advice to use Apt for this though).

  10. #10
    Just Joined!
    Join Date
    Aug 2005
    Posts
    26
    Quote Originally Posted by jens
    Yep... you're using incompatible repos.
    You can only mix Livna.org with fedora.us(my advice, don't use either of them).
    Remove Livna and add DAG(you could also add Dries and many more):
    http://dag.wieers.com/home-made/apt/
    Nex try to remove everything from Livna and reinstall it from your new yum.conf(I still advice to use Apt for this though).
    thanks!
    fixed now..

    One more question thoug: what do I install to be able to get .wmv and .asf files to play in mplayer?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •