Find the answer to your Linux question:
Results 1 to 7 of 7
Please help. I am running FC 3 on a desktop computer I have and am trying to do some transfering of files to my laptop via an external firewire hard ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    VFAT32 Issues


    Please help. I am running FC 3 on a desktop computer I have and am trying to do some transfering of files to my laptop via an external firewire hard drive. I partitioned the HD with Partition magic with a large NTFS partition, medium VFAT32 partition, and small ext3 partition. I can 'see' all the partitions in Linux and move files to the VFAT and ext3 partitions, but I cannot get the VFAT partition to give me write permissions. I have made sure the mount point has permissions open for anyone to read, write, or execute, but when the partition is mounted the write option is 'unselectable' even in root. The major issue is that while I can move files to the VFAT partition I cannot get them to be other than read-only in Windows. Nor can I get Linux to let me give all users write permissions. Has anyone found a solution to this. Again I have FC 3 on my desktop and am trying to import the files to WinXP Home on my laptop. Any way to get the files available for both read and write on my laptop would be a victory.

    Thanks,

    Mark

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    have you tried mounting it with
    Code:
    mount -t vfat -o rw,umask=002 /dev/sda2 /mnt/sda2
    (replace the drive and teh mount point with ones you want ot use)
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    edit /etc/fstab as root and change the line with that hard disk where it says somthing like users,auto,ro to users,auto,rw

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    I have now tried all the above. I have enabled file sharing through windows, changed the lable of the partition and nothing changes. The drive is seen, but even as root I can't change the permissions for other users and the group. The owner has rwx, but can't set that for anyone else.

  6. #5
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    I had this problem before. The fstab entry should be:
    PARTITION-DEVICE MOUNT-POINT vfat rw,umask=0,nosuid,nodev,users 0 0

  7. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Is this an incorrect assumption:

    I assumed that I would be able to write files to my external hard drive vfat32 partition in linux, then attach the drive to my XP Home machine and access those files in a read/write manner.

    I gave a try to the above mentioned edit of the /etc/fstab and still am unable to get full access. Any other ideas, or am I trying to do the impossible.

    Thanks for the help thus far.

    BTW, I have tried to copy and paste the files off the VFAT partition on the external hard drive to my laptop (XP) hard drive, when they get there they are read only and I am unable to change that through the windows utility (I know a windows question on a linux board). Thanks for the help.

    Makr

  8. #7
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    su -c "chown YOUR-USER MOUNT-POINT;chmod 777 MOUNT-POINT"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •