Find the answer to your Linux question:
Results 1 to 10 of 10
theres crackling coming on any sound output on my linux distro only... the sound is clear on windowsXP.... when i goto system settings--> soundcard detection it shows my sound card ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    52

    sound crackling only on linux


    theres crackling coming on any sound output on my linux distro only...

    the sound is clear on windowsXP....

    when i goto system settings--> soundcard detection

    it shows my sound card & plays teh test sound Clearly...no crackling there at all...but everywhere else it crackles....

    this crackling was present all day yesterday....somehow today all day it stopped crackling(after rebooting i.e.) & now after i rebooted, crackling has resumed...

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try running this command as root in the terminal:
    Code:
    alsamixer
    Use Up/Down keys to Increase/Decrease and Left/Right keys to move from one option to another. If there is a MM under an entry, it means it is muted, press M to unmute it.

    I would suggest you decrease it to about 80% of max, if crackling still presists, decrease further.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    52
    i decreased every possible option to 0 except the one required & kept it at about 0%..

    crackling still persists.....on alsa as well as esd...

    surprisingly when i do soundcard detection & play test sound...the sound is crystal clear

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    in which program are you experiencing the crackling?
    Life is complex, it has a real part and an imaginary part.

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    52
    rythmbox,vlc, & even the system sounds crackle....
    i dont ve xmms.

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    hmmm, try this, goto the KDE Control Center -> Sound and Multimedia -> Sound System -> Hardware. Under the audio device section, play around with the options available, for me the Open Sound System seems to work best.

    Also in the rythmbox and vic settings menu, is there a choice of which sound system to use?

    Another thing, have you checked that the connection between speaker and sound card is fine?
    Life is complex, it has a real part and an imaginary part.

  8. #7
    Just Joined!
    Join Date
    Aug 2005
    Posts
    52
    no choice in music player or vlc...

    i am on gnome...

    in the volume control--> preferences
    there are 2 devices which i can use...Realtek ALC880(OSS Mixer) & HDA Intel(ALSA Mizer)

    & both crackle...

    the connection betn speaker & sound card is fine...on winXP sound is clear...

  9. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    52
    funny.....suddenly a song was playing clear in mplayer & then my gnome had some problems so i killed X & re-logged in & teh sound is horrible again...

  10. #9
    Just Joined!
    Join Date
    Aug 2005
    Posts
    52
    well i made the changes in control centre--> sound & multimedia-->sound system--> hardware...

    ESD & ALSA create crackling while OSS gives clear output....

    but problem is i selcet OSS & Apply...the sound server is restarted...

    but when i try to play any file in music player it gives me the error:
    ALSA device "default" is already in use by another program...

    wat do i do to make OSS the default & make all application use OSS & to resolve this conflict...

  11. #10
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    I have the same problem too

    someone who also had this problem posted this site:
    http://forums.fedoraforum.org/showthread.php?t=51499

    the solution involves fixing the sound crackling in ESD... so you may not have to modify everything to use OSS.
    i havn't fixed the problem yet but it might work for you.

    as for your last question...
    what do i do to make OSS the default & make all application use OSS & to resolve this conflict...
    i'm not an experienced linux user but maybe "arts" is running (or the gnome equivalent) try going to the process manager and killing artsdaemon or esd... maybe that is your problem...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •