Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, very new to linux, just installed madrake 10.1 love it till i had to setup wireless internet, searched the internet learned of a utility called ndiswrapper downloaded it on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    wireless on linux mandrake


    Hello,
    very new to linux, just installed madrake 10.1 love it till i had to setup wireless internet, searched the internet learned of a utility called ndiswrapper downloaded it on my windows xp and extraced the zip file and burned to a cd to take it to the linux computer and went to read the insturctions, it said

    "Make sure there is a link to the kernel source from the modules directory. /lib/modules/VERSION/build should be a link to the kernel source, where VERSION is the version of the kernel you are running. If there is no link, you'll get an error at the make install step." and then said to type this command
    ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build
    my question is where do i type this command in the run or where. I know my kernal version is 3.2 is says that when its booting. it says if the link doesnt exist, it then says to type this command
    tar zxvf ndiswrapper-version.tar.gz
    wuts that again where do i type it lol so confused there are more command but i typed them in a terminal and i got a error saying make :*** stop when i typed "make distclean" etc to compile and install it
    here is the link for the instructions
    http://ndiswrapper.sourceforge.net/m...p/Installation
    thank you for all your help

  2. #2
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    You'll need to install the kernel source, but you'll also need to find out your kernel version. The 3.2 you see when it is booting is acutally the KDE (K Desktop Environment) version. To find out your kernel version, you'll need to open up a terminal/CLI, which you can find as a quick launch icon on the taskbar that looks like a monitor (should say konsole or terminal when you mouse over it). Once you have one open, type in:

    Code:
    uname -r
    That should give you your kernel version. Then install your kernel source. I don't remember the exact path in the Kmenu for Mandrake, but you should be able to find a Install Software option under the System option in your Kmenu/start menu. Once you're there, do a search for kernel source and look the same version as the kernel version you're running.

    After you have that installed, you can then:

    "Make sure there is a link to the kernel source from the modules directory. /lib/modules/VERSION/build should be a link to the kernel source, where VERSION is the version of the kernel you are running. If there is no link, you'll get an error at the make install step." and then said to type this command
    ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build
    The rest of the commands for the NDISwrapper installation found on the install page can be type in the terminal/CLI. Hope this helps.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    almost worked

    Hey thanks for your quick reply,
    i did what you said and it kind of worked, i went to the install software option and seached for kernel source in the results my kernel is not there becuase my kernel is 2.6.8.1 -12mdk in the search results there are 2.6.8.1.12 so i installed that one, the link was almost made a directory was made but there is no folder called build as in the instructions, and when i type ln -s /usr/src/linux-<2.6.8.1 -12mdk> /lib/modules/2.6.8.1 -12mdk/build
    i get a error saying directory not found etc, so confused
    thanks for your help

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    Try removing the brackets from: /usr/src/linux-<2.6.8.1 -12mdk>

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    nope

    it said command not found thanks

  7. #6
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    Also, make sure to remove the spaces form 2.6.8.1 -12mdk on both. Should just be 2.6.8.1-12mdk. Hope that works out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •