Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Location
    Belgium
    Posts
    8

    Stuck in commandline mode


    I just tried to setup a dualhead system but by doing this I stranded at runlevel 3 !

    How did this happen ?
    I opened Yast , set my monitor to
    text mode only and rebooted.
    The next thing that happened was that
    indeed both of my monitors came back to live
    instead of one but I cannot get out of this
    mode anymore.
    I tried to start the X server with the "startx"
    command and the answer I got was ...

    "There is no link /var/XR6/bin/X to the
    correct X server binary.
    Please configure the correct X Server
    with SaX/SaX2, which will create the
    missing link. I'm aborting now"

    I went to see if /var/XR6/bin/X still even
    existed because it was there 10 minutes ago
    and it wasn't !!!!!

    What to do ???? Please help !!
    S.O.S from the commandline island
    from a green linux newbie !!

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    First I think you need to be in run level 5, so use "init 5" to do this.
    Then run "sax" or "sax2" to run the X configuration routine.
    This all needs to be done as root by the way.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    Luton, England, UK, Earth
    Posts
    639
    try the command startx, though you might want to do xorgcfg first

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •