Find the answer to your Linux question:
Results 1 to 2 of 2
Hi! I have trouble installing sound on my IBM laptop. I tried several things which were said would fix it but I still get this error: Error while initializing the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    15

    Problem with sound on IBM X30


    Hi! I have trouble installing sound on my IBM laptop. I tried several things which were said would fix it but I still get this error:

    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.

    On the net I found out that ALSA drivers support my sound, but nothing changed after I installed them too...

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    54
    What kernel version are you using?
    Depending on what version you have depends on wether or not you need alsa-drivers. Version 2.6.x and up have built in support while 2.4.x and below require alsa-drivers. Both can benifit from alsa-tools, but is not neccessary on either.

    If you have a 2.6.x kernel, are the right drivers compiled into the kernel?
    If you do have a 2.4.x kernel and you installed alsa-drivers, and alsa-tools, what does the output of lsmod show?

    What part of alsa did you install? Alsa-tools, alsa-drivers,alsa-firmware, etc..


    What sound card do you have exactly?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •