Find the answer to your Linux question:
Results 1 to 10 of 10
Well i have an optical mouse with the scroll button between the buttons.. But when i scroll with it it don't do anything it just works like a click.. Any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    27

    mouse


    Well i have an optical mouse with the scroll button between the buttons.. But when i scroll with it it don't do anything it just works like a click.. Any help? .. I run off KDE 3.1 Slackware 9.0

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Do you have this in the mouse section of your edit your /etc/X11/xorg.conf file?

    Code:
    Option "ZAxisMapping" "4 5"

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    It should look something like this:

    Code:
    Section "InputDevice"
    
    # Identifier and driver
    
        Identifier	"Mouse1"
        Driver	"mouse"
        Option "Protocol"    "IMPS/2"
        Option "Device"      "/dev/input/mice"
        Option "ZAxisMapping" "4 5"

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2006
    Posts
    27
    i don;t have a /etc/X11/xorg.conf file =/

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Have you run "xorgconfig" as root yet?

    If not, you'll have a chance to setup your mouse, monitor, video card, and keyboard when you do.

  7. #6
    Just Joined!
    Join Date
    Jan 2006
    Posts
    27
    How would i run xorgconfig i tryed terminal and run command

  8. #7
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    What distro are you using? The file you may be looking for might be at /etc/X11/XF86Config-4

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  9. #8
    Just Joined!
    Join Date
    Jan 2006
    Posts
    27
    Slackware 9.0

  10. #9
    Just Joined!
    Join Date
    Jan 2006
    Posts
    27
    i found
    /etc/X11/XF86Config
    /etc/X11/XF86Config-fbdev
    /etc/X11/XF86Config-vesa

  11. #10
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Yeah, Slackware 9 was probably still using xf86config rather than xorg.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •