Find the answer to your Linux question:
Results 1 to 10 of 10
oddly enough... the samba share to a /storage directory i created as public to any user with read/write priveleges still wont let me write to it. any reasons why that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Posts
    7

    still battling samba



    oddly enough... the samba share to a /storage directory i created as public to any user with read/write priveleges still wont let me write to it. any reasons why that is?

    heres the weirdest thing to me:
    i also have a same all access share to the root directory on 2 linux boxes. i am ONLY able to move files into the /tmp directory, anywhere else it gives me access denied. SOMEONE PLEASE HELP IM RUNNING OUT OF HAIR TO PULL!!!!! thanx in advance

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I'm fairly sure that you have to enable write access explicitly in smb.conf. Would you mind posting the corresponding section from it?

  3. #3
    Just Joined!
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Posts
    7
    id like to but im not sure which part you want... i had to reinstall today because when i opened up smb.conf and tried some new stuff my redhat-config-samba stopped working entirely even after reboot, and then again even after i removed then added it back into system. one thing i dont get is that in smb. conf writeable is spelled "writable" in all of the examples, but redhat-config-samba uses the correct spelling when specifying writeability. its a mute point anyway because neither spelling corrected my problem. heres what i have for a single share to a RAID partition mounted to /storage:

    [storage]
    path=/storage
    writeable=yes
    guest ok=yes

    it is important to know that i can see and open this folder from win xp and win 2000 and i can see lost & found but cant open to view it. my problem, again, is writing from these machines to the new drive, and its a big problem because this computer is meant to solely be extra storage.
    i've also tried putting public=yes into [storage], and as previously stated i've tried changing the spelling of writeable to the spelling they use in the .conf file. hopefully this is enough to get a workable answer. thanks again.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    OK... did you set the right UNIX permissions on /storage itself?

  5. #5
    Just Joined!
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Posts
    7

    if you mean

    with chmod no i just discovered that command. hopefully thats what you mean because if not im about to do more severe damage to my comp lol. thx for walking me through this and please let me know if chmod is the right thing to do thanx

  6. #6
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    Code:
    su
    chmod 777 /storage
    that will make the directory /storage to be read,write,execute for everyone
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  7. #7
    Just Joined!
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Posts
    7

    happy to report

    that i can now write to diretories other than /tmp. sad to report that for some reason my printer configuration will recognize my laserjet 4000 on jetdirect port 0 (when its actually on port 1) but wont recognize my deskjet 970 on any port (whenitis supposedly on port 2). Both printers work frommy windows machines. any advice?

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Would you mind telling me what this "jetdirect" thingie you're referring to is?

  9. #9
    Just Joined!
    Join Date
    Jan 2004
    Location
    New Jersey, USA
    Posts
    7
    hp jetdirect the windows print server.
    it is set up as its own ip 192.168.0.7 and it should be (from the jetserver printout) port 1 is laserjet 4000 port 2 is deskjet 970.
    redhat-config-printer keeps giving me a Network host 192.168.0.7 is busy; will retry in x seconds when it tries to send test page.

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh. Sorry, I know nothing about this jetdirect thing. I've only heard its name mentioned in obscure places. Can't help you with that. =(

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •