Find the answer to your Linux question:
Results 1 to 5 of 5
Hello. I'm trying to make a file server out of my Linux box, but it doesn't want to co-operate. I got FC5 installed. Here is part of my code from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! vitalka's Avatar
    Join Date
    Oct 2004
    Location
    Toronto, ON
    Posts
    77

    Can't see samba share.


    Hello.
    I'm trying to make a file server out of my Linux box, but it doesn't want to co-operate. I got FC5 installed.

    Here is part of my code from smb.conf:

    [public]
    path = /home/public
    public = yes
    writable = yes
    printable = no
    read only = no

    I want for any one to be able to access it on my home network.

    I can see Linux box showing up on the network (on my WinXP machine) but if I try accessing it, I get this error message:
    ' \\Localhost is not accessible. You might not have permission to use this network resource. '

    I chmod public share to 777, but still no go.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by vitalka
    I chmod public share to 777, but still no go.
    So you
    Code:
    chmod -R 777 /home/public
    on the server.

    Do you want to make it a server with authentication or not?

    If not, make sure you have a line like that in your /etc/samba/smb.conf:
    Code:
    security = share
    Plus, does
    Code:
    testparm
    says it is all ok?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined! vitalka's Avatar
    Join Date
    Oct 2004
    Location
    Toronto, ON
    Posts
    77
    Thanks a lot. Got it to work.

    'security = share' was the line I needed.

  4. #4
    Just Joined!
    Join Date
    Nov 2007
    Posts
    1

    Question

    Quote Originally Posted by antidrugue View Post
    So you
    Code:
    chmod -R 777 /home/public
    on the server.

    Do you want to make it a server with authentication or not?

    If not, make sure you have a line like that in your /etc/samba/smb.conf:
    Code:
    security = share
    Plus, does
    Code:
    testparm
    says it is all ok?
    No !
    I can't access.
    testparm given error.

    [root@localhost ~]# testparm
    Load smb config files from /etc/samba/smb.conf
    Processing section "[share]"
    Unknown parameter encountered: "creat mask"
    Ignoring unknown parameter "creat mask"
    Unknown parameter encountered: "creat mode"
    Ignoring unknown parameter "creat mode"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions

    # Global parameters
    [global]
    netbios name = SERVER1
    security = SHARE
    encrypt passwords = No
    mangling method = hash

    [share]
    path = backup/
    read only = No
    directory mask = 0777
    guest ok = Yes

    this is what I get.

  5. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    sis1778,
    It looks like you have some syntax errors in smb.conf
    Unknown parameter encountered: "creat mask"
    Unknown parameter encountered: "creat mode"
    Shouldn't that be
    "create mask"
    "create mode"
    And you should really start your own threads, this one is over a year old.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •