Find the answer to your Linux question:
Results 1 to 6 of 6
I was trying to install the ati driver for my card but there was one problem. Apparently you need to know what version of Xfree86 you are running. Once known, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22

    determining XFree86 version


    I was trying to install the ati driver for my card but there was one problem. Apparently you need to know what version of Xfree86 you are running. Once known, you can download the corresponding driver that matches you Xfree86 version.
    Okay, so it said:
    "If you are not sure which version of XFree86 you have installed, please download and run Check.sh from a command line to find out."
    (http://www.ati.com/support/drivers/l...9&submit=GO%21)
    i downloaded this little thing and had it saved in my user folder. i ran it
    Code:
    [tim@localhost tim]$ cd /home/tim
    [tim@localhost tim]$ ls
    Check.sh  Desktop  windows
    [tim@localhost tim]$ Check.sh
    : bad interpreter: No such file or directory
    (wats an interpreter???)
    then i tried putting the file in /bin because i think thats where the commands are kept. opened up the terminal, ran the command, and the same error about a bad interpreter.
    Firstly, could somebody help me to work this problem out. And, although it might defeat the purpose, im sure there is an easier way to found out what version you are running of XFree86.
    I also used su too for root permissions and no success. Also, is there a way i can have fedora recognize commands, files, folders, etc. without the correct case(as in 'A' and 'a')
    BTW, my sys is a dual boot w/ fedora and winXP
    any help is greatly apprieciated! thanks

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try this:

    Code:
    XFree86 -version
    at a shell prompt.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22
    great. thank you sarumont. Got the right one! however i ran into one problem. I chose the correct driver, robooted and the GUI looked funny first of all, and when the little icons load up before you see the login prompt, it stalled. i then pushed the button on my computer to forcefully shut it off and rebooted once again. at the white text on black screen thingy, when you load up the OS, it said something like that linux had been improperly shut down, which was true, and now i was at a "repair-filesystem" prompt.
    Now thinking about what caused this problem, i needed to get that old driver back.
    Luckily, when i made my driver changes, linux told me that it had made a backup named XF86Config.backup. I now need to replace this backup with the original. went to /etc/X11. there were the two files i need to replace, XF86Config and XF86Config.backup. i opened them both w/ vi and saw the difference in drivers under the Device section.
    I typed in, now bear with me, i had to write this down so i could explain it here, so might not be accurate.
    Code:
    mv XF86Config.backup XF86Config
    mv: cannot move 'XF86Config.backup' to 'XF86Config': Read-only file system
    This is where i get stuck. I dont know how to edit these files. it said read-only, meaning no writing, right? What should i do?

  4. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    First off, were you root when you tried this? If not, be root.

    If it doesn't work as root, then it sounds like the parent partition of /etc is being mounted read-only at boot. If you've been able to edit this before, I would guess that it's because of the filesystem errors. Run an fsck on the partition then reboot. That should remedy that.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  5. #5
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22
    yes, i am root. still didnt work.
    the thing is when i would boot up linux it would just go to the repair-filesystem prompt, the gui wouldnt even load. i ran fsck and that workt wonders, one of them was making my gui load up again. but it would still stall at this one portion.
    If i could somehow edit the filesystem, normally(not in that repair mode), i could make my changes. is there a way to boot to the white text on black screen thing?i think you call it a shell, not sure.

  6. #6
    Just Joined!
    Join Date
    Aug 2003
    Location
    Cowpens, SC
    Posts
    96
    If you made a Linux boot floppy, that should get you to a Console screen, or you may have an option in the bootloader (grub, lilo). You may have permissions set wrong on the files themselves to be able to write to them (ls -a, I think, but run ls --help to be sure) I'm on the Win side of mine right now, and can't check it

    You may even be able to run linuxconf, and stop the GUI from loading at startup. Next time, try ctrl+alt+backspace to restart the GUI, rather than the reset button. Linux isn't quite as forgiving as window$ on improper shutdowns.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •