Find the answer to your Linux question:
Results 1 to 8 of 8
i am having a problem with mounting my ntfs partition. Right now im running a dual boot system, with Fedora and WinXP, and trying to mount the WinXP.i followed jokerdave's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22

    mounting ntfs


    i am having a problem with mounting my ntfs partition. Right now im running a dual boot system, with Fedora and WinXP, and trying to mount the WinXP.i followed jokerdave's posting, which Dillinger helped out with(here), and that started me off.
    i type:
    Code:
    [tim@towerofpowerx tim]$ su
    Password:
    [root@towerofpowerx tim]# mount -t ntfs /dev/hda1 /home/tim/windows
    mount: fs type ntfs not supported by kernel
    NOTE: i already made the /home/tim/windows folder and i trial and errored with the hda#s, bc i dont know mine, but still this error.
    what should i do? im thinking im gonna hafta update my kernel, but its strange because this version of Fedora is brand new. i would be more specific on what version it is, but i dont know how to find that out.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Fedora doesn't ship with the NTFS driver. Check out http://linux-ntfs.sf.net/ to download it.

  3. #3
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22
    thanks dolda, i ran the rpm and i got it working. but now, a new error message!! heres da stuff
    Code:
    [root@towerofpowerx tim]# mount -t ntfs /dev/hda6 /home/tim/windows
    mount: /dev/hda6 is not a valid block device
    wat now? and hda6 is just the last number i stopped at. Perhaps if i knew which exactly which hda it was, i might be able to go more indepth. How would i determine this, but more importantly, could someone help me with the valid block device problem? thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Check with "fdisk -l /dev/hda" which partition it is on.

  6. #5
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22
    Code:
    [root@towerofpowerx tim]# fdisk -l /dev/hda
    bash: fdisk: command not found
    haha. any ideas?

  7. #6
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    use cfdisk instead

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Try "/sbin/fdisk -l /dev/hda". Or, become root with "su -" instead of just "su".

  9. #8
    Just Joined!
    Join Date
    Dec 2003
    Location
    my desk
    Posts
    22
    aha. i got it!!! i figured it out. i remebered when i installed linux and selected the partions, Partition Druid called my partitions by s's instead of h's(as in sda vs. hda) i dunt know why, but i tried this:
    Code:
    [root@towerofpowerx tim]# mount -t ntfs /dev/sda1 /home/tim/windows
    [root@towerofpowerx tim]# cd /home/tim/windows
    [root@towerofpowerx windows]# ls
    attempt                 I386              pagefile.sys
    boot.ini                IO.SYS            Program Files
    BOOTLOG.TXT             MSDOS.SYS         RECYCLER
    BOOTSECT.DOS            My Shared Folder  System Volume Information
    Documents and Settings  NTDETECT.COM      USR
    DRVSPACE.BIN            ntldr             WINNT
    hiberfil.sys            os643467.bin
    there it is! It worked!!! i was just about ready to give up.
    thanks for the help though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •