Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
If you run Code: mount -t ext2 /dev/fd0 /floppy you will need to have a dir at the root ( / ) called floppy. The last part of the script ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User
    Join Date
    Jan 2004
    Posts
    357

    If you run

    Code:
     mount -t ext2 /dev/fd0 /floppy
    you will need to have a dir at the root ( / ) called floppy. The last part of the script "/floppy" is where you want to mount it and needs to exist. The mount point does not need to be under /mnt. The example that I gave above has you "cd /" then "mkdir floppy". If you did that then it would have worked.

    Or if you already have a dir /mnt/floppy and that is where you want to mount the floppy run

    Code:
     mount -t ext2 /dev/fd0 /mnt/floppy
    Notice the difference in the two scripts?

    and note: if ext2 doesn't work use ext3

  2. #12
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66
    I see where I didn't have a floppy directory in /

    I tried it with /mnt/floppy but it still won't accept a floppy it has formated in native linux

    bash-2.05b# mount -t ext2 /dev/fd0 /mnt/floppy
    mount: wrong fs type, bad option, bad superblock on /dev/fd0,
    or too many mounted file systems
    bash-2.05b# mount -t ext3 /dev/fd0 /mnt/floppy
    mount: wrong fs type, bad option, bad superblock on /dev/fd0,
    or too many mounted file systems

  3. #13
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    So did you ever try (as in my first post above)

    umount /mnt/fd0


    before trying to mount

    The error you give sounds very much like your OS already thinks that the floppy is already mounted, but somewhere that you don't know. umount (as in unmount) and then try again. or if that fails, reboot your machine, unmouninting everything that isn't setup at boot and try to mount again. Using all of the above and you will have good results.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    do this: mke2fs /dev/fd0

    then this: mount /dev/fd0 /mnt

    now the ext2 floppy will be mounted in the directory /mnt which is where you can accses it useing a file browser of via a consol.

  6. #15
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66
    I did try umount on /dev/fd0 and /mnt/floppy with no success. I didn't reboot though.

    I have been trying to reconfigure my CDRW and CDROM since I changed the cables from IDE2 to each on IDE1 and IDE2. Somehow between trying to create sym links for the new CD drive configuration or trying to get this floppy to read in ext2, well I lost my floppy all together and the CDRw has not worked since the cable change.

    Now I'm scared. I've been giving this system all kinds of commands and it was just a matter of time before I crashed. I reinstalled : /

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •