Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I can use DOS floppies but when I format a floppy with ext2 I can't mount it or acces it. I get this; bash-2.05b# /mnt/floppy bash: /mnt/floppy: is a directory ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66

    floppy format


    I can use DOS floppies but when I format a floppy with ext2 I can't mount it or acces it. I get this;

    bash-2.05b# /mnt/floppy
    bash: /mnt/floppy: is a directory
    bash-2.05b# mount /dev/fd0
    mount: wrong fs type, bad option, bad superblock on /dev/fd0,
    or too many mounted file systems

    The RedHat manual says to use /mnt/floppy and that doesn't work. Should I just use DOS formatted disks?

    Thanks for any input,

    Signed,
    Maybe Linux is to hard : ( I better go back to windoz

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It's possible that the RedHat installer has specified that floppies should have FAT on them. Can you post your /etc/fstab?

  3. #3
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66
    Thanks for the help. Here is my fstab;

    bash-2.05b$ cat /etc/fstab
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hdg3 swap swap defaults 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
    /dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0


    While I have you, why is my prompt no longer user@localhost and now bash-2.5b$
    This just started after a RedHat update.

    Thanks again

  4. #4
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Try running
    Code:
    mount /mnt/floppy
    You where trying to mount /dev/fd0 without giving a mount point it should have been
    Code:
    mount /dev/fd0 /mnt/floppy

  5. #5
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66
    Thanks for the help. I get this with those commands on a 3.5" disk formatted in ext2;

    bash-2.05b# mount /mnt/floppy
    mount: wrong fs type, bad option, bad superblock on /dev/fd0,
    or too many mounted file systems
    bash-2.05b# mount /dev/fd0 /mnt/floppy
    mount: wrong fs type, bad option, bad superblock on /dev/fd0,
    or too many mounted file systems

  6. #6
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    I've had good results under RedHat (9 and fedora) with this

    To mount an ms-dos floppy, make a directory where you would like to mount it.
    Code:
     cd /
    Code:
     mkdir /floppy
    Then issue this command
    Code:
     mount -t msdos /dev/fd0 /floppy
    To mount a floppy that is formatted for Linux (ext2 or ext3) simply change msdos above to ext2 or it might be ext3. Your enviroment might (and probably will) be different.

    ----------------------------------------------------------------------------------

    edit added after reading your above post

    if you are getting the "too many file systems mounted" error. try something like this. And then do the above again.

    Code:
     umount /mnt/fd0

  7. #7
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Sorry i thought you had problems with mounting FD formated EXT2/3 but it seems your question has changed you asked about a EXT2/3 disk now you are talking about FAT32 please dont make us look like fools by changing you question half way though EDIT :_ Im sorry it was another post i thought it was by the same person. Sorry i have realised someone posted half way though the post im sorry, But you must be doing someting wrong it should be mke2fs /dev/fd0

  8. #8
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66
    Thanks for the help. I didn't mean to cause confusion. I don't see anything in any of my posts about FAT32. My problem is mounting a floppy formatted in EXT2.

    When I run this command;
    bash-2.05b# mount -t ext2 /dev/fd0 /floppy

    I get this
    mount: mount point /floppy does not exist

    Maybe my RedHat will only read DOS disks?

  9. #9
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    that message simply means that the dir /floppy doesn't exist... check to see if you have a /mnt or /mount dir and then check to see if there is a ./floppy dir within one of those two...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  10. #10
    sam
    sam is offline
    Just Joined!
    Join Date
    Nov 2003
    Location
    Ky
    Posts
    66
    Yes I have a mnt directory with a floppy directory in it.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •