Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, all! I just decided it was time I gave linux a try on one of my machines, to see if the stability and usability was worth making the change. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    1

    Major mouse problems - Ark Linux


    Hello, all!

    I just decided it was time I gave linux a try on one of my machines, to see if the stability and usability was worth making the change. I really only had one piece of software on that machine (an eBay auction management program) that wasn't on my other machine, so I dragged that on over, and installed the newest version of Ark Linux. Don't know why I chose this distribution, except that it is designed for Linux newbies like myself.

    Anywho, throughout the instalation, anytime I moved my mouse right or left, the cursor moved up and down, and it seemed like I was clicking the mouse even though I wasn't. I decided to go through the instalation process and see if it worked itself out once the OS was completely installed. However, it didn't.

    I tried connecting the mouse from my laptop, and it works fine. Problem is, it came with the laptop, and it was designed for the laptop. It has about a 2-foot (max) cord. This means that I can use my mouse on the linux machine, but only if I lay it on the floor.

    The mouse I am having trouble with is a Microsoft Standard Wireless Optical Mouse. (I know, want to migrate from Windows, and I'm using MS-branded hardware... but keyboards and mice are largely about ergonomics, and the MS "entry" mice and keyboards are by far the most comfortable for me.)

    The mouse is connected to the computer via a USB KVM switch, which does appear to work fine, as my MS USB keyboard works fine on the linux machine. As a test, I connected the base of the mouse directly to the linux machine, bypassing the KVM, and it made no difference. When actually in the OS, it is quite obvious that moving the mouse left-right is being interpreted as clicks, etc. The curser moves up and down, but things get selected without me touching a mouse button, etc.

    Does anyone have any suggestions? I don't know much about Linux yet, but I really can't play with it until my mouse is working. Did I chose the wrong distribution? Do I need a driver for my mouse?

    One other thing I thought of is that the machine I put Linnux has the oldest MB of the machines I'm running, and as such does not have USB 2.0 on board. Since I've never used any high-speed devices on the machine, I've felt content to leave it USB 1.1. However, I thought I would share this info, in case it is relavent.

    Please let me know any suggestions you may have. In the mean time, I think I'm going to go get some of the work done I should have been doing instead of attempting to install Linux on one of my machines.

    Thanks,

    M.J. in Colorado
    "Gayrockies"

  2. #2
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    I think you have wrong driver or protocol for your mouse. Check the /etc/X11/xorg.conf -file.
    You should have there an entry something like that:
    Code:
    Section "InputDevice"
            Identifier  "Mouse0"
            Driver       "mouse"
            Option      "Protocol" "auto"
            Option      "Device" "/dev/psaux"
            Option      "ZAxisMapping" "4 5"
    EndSection
    You may post here yours.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •