Find the answer to your Linux question:
Results 1 to 10 of 10
Hey, I got some programs from sourceforge.. as .tar.gz and when I was installing them I did the following: 1- tar xvzf file.tar.gz which worked fine... 2- ./configure which worked ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    30

    A problem with 'make'...


    Hey,

    I got some programs from sourceforge.. as .tar.gz and when I was installing them I did the following:

    1- tar xvzf file.tar.gz which worked fine...
    2- ./configure which worked fine too...
    3- make

    Then it says the following (with make, make install, make all...)

    make: *** No targets specified and no makefile found. Stop.


    Note: I was logged as root... and the folder has three files :

    Makefile.in
    Makefile.am
    Makefile.mingw

    Any help guys...

    Thanks

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Which distro? Which programs? Did you read the "INSTALL" or "README" files of the programs you are trying to install?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    When it says "no makefile found" it means that
    ./configure failed in some way, and did not create the
    makefile. Run configure again and carefully watch
    the messages it puts out.

  4. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    30
    Actually yeah the ./configure failed... it says:

    GLib 2.0

    How do I get that on Mepis

  5. #5
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    O.o you're missing glibc? That's a pretty major component of, like, everything. I take it that you don't have gcc installed (which you'll need anyway), so just run:
    Code:
    apt-get install gcc
    from the commandline.

  6. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Or even the set of "bare minimum" tools in order to compile :
    Code:
    apt-get install build-essential
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  7. #7
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    I think they're missing Glib, not glibc. So it's probably something like this:
    Code:
    apt-get install glib
    If that doesn't work, try apt-cache search glib and install what matches Glib 2.0.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  8. #8
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by Javasnob
    I think they're missing Glib, not glibc. So it's probably something like this:
    Code:
    apt-get install glib
    If that doesn't work, try apt-cache search glib and install what matches Glib 2.0.
    Hum... you are right. Then :
    Code:
    apt-get install libglib2.0-0
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #9
    Just Joined!
    Join Date
    Apr 2006
    Posts
    30
    actually it says that my libglib 2.0 is installed and is latest version... i tried installing some stuff on Synaptic package manager and now it find glib but it gives an error that i dont have gtk+ installed but i do... How can refer to the path of gtk+ and how do i even know it?

    Thanks

  10. #10
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by abdo88
    it gives an error that i dont have gtk+ installed but i do... How can refer to the path of gtk+ and how do i even know it?
    Perhaps installing the gtk+ development files would solve this :
    Code:
    apt-get install libgtk2.0-dev
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •