Find the answer to your Linux question:
Results 1 to 7 of 7
I'm trying to edit /etc/ppp/options, but I keep getting denied permission as root user. How do I acquire permission? I thought root user had access to everything....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    8

    /etc/ppp/options


    I'm trying to edit /etc/ppp/options, but I keep getting denied permission as root user. How do I acquire permission? I thought root user had access to everything.

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    when you enter
    Code:
    ls /etc/ppp/options -alF
    what doe you get?

    I get the following on my Fedora Core 1 PC :-
    Code:
    -rw-r--r--    1 root     root           96 Dec  8 18:48 /etc/ppp/options
    which tells me that as root I can read and/or write to this file, while as other users I can only read, and that nobody is allowed to execute it (-rw-r--r--). The change this I simply enter
    Code:
    chmod 646 /etc/ppp/options
    and it should then show as

    Code:
    -rw-r--rw-    1 root     root           96 Dec  8 18:48 /etc/ppp/options
    which of course means tha you, as a normal user could write to it (ie. edit it).

    For more on chmod, try "info chmod"


    have fun

    Nerderllo

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    8
    When I type ls /etc/ppp/options -alF at the command line I get the exact same output: -rw-r--r--. According to this, I should be able to access it as the root user. Do I have a corrupted directory?

  4. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    try the chmod command and see if it changes the settings first.

    By the way, why do you want to edit this file?

    have fun
    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  5. #5
    Just Joined!
    Join Date
    Feb 2004
    Posts
    8
    I just changed all the permissions to read: -rwxrwxrwx

    Now I don't get the permission denied message, but I get this:

    /etc/ppp/options: line 1: lock: command not found

    I'm trying to edit the file because when I try to dial out with kppp the pppd dies right before I connect. I've read that if you edit line 35 of /etc/ppp/options that it might solve the problem.

  6. #6
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    oh, I've hadd pppd die on me, right after dial, but that turned out to be down to me not having my ISP's userid and password in /etc/ppp/chap-secrets and /etc/ppp/pap-secrets.

    good luck

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  7. #7
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    yeah most ISP's use pap authentication but some now use chap which is more secure anyway. edit /etc/ppp/chap-secrets and add your username and password where it tells you to.. in this format:


    username * password

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •