Find the answer to your Linux question:
Results 1 to 9 of 9
;p the installation of rh8 went smooth but after i finished setting up eth0 ( i have a 10/100 Ethernet LAN on system board ),it still wont work ( it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    10

    rh8 on dell inspiron 8200


    ;p the installation of rh8 went smooth but after i finished setting up eth0 ( i have a 10/100 Ethernet LAN on system board ),it still wont work ( it was automatically detected during the setup of rh8 installation ) rebooted and pressed f2 to enter bios setting .. all ethernet/lan settings are enabled. went back and fired up rh8 network setting ( redhat-config-network ) and tried to activate it .. still none luck. decided to create xDSL device since i mainly use dsl connection .. so i thought i might can setup it up on teh rh8 sys so it can might recognize the dsl modem .. and connect to the ISP of mine. still no luck. ;p thought i might can get some help here heh. ( all i know is that i gotta turn eth0 on first before activiating teh dsl connection )

    [pardon my language, english is my second langage heh however i'd glad to explain more better if u want]

  2. #2
    Just Joined!
    Join Date
    Feb 2004
    Posts
    10
    bump

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    In what way doesn't it work (ie. do you get an error, abnormal behavior, etc...?)? What is it connected to? If it's connected to a DSL modem, does your ISP use PPPoE or anything like it? Also, please attach the output of the following commands:
    Code:
    /sbin/ifconfig -a
    grep eth0 /etc/modules.conf
    /sbin/lsmod

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2004
    Posts
    10
    [ its long .. so bear with me

    ( dsl modem ( or box if u call it ) + cat cable line that connect between dsl modem and ethernet card .. the plm is that i think redhat linux still hasn't recognized ethercard onboard yet OR just cant communicate with it .. DSL modem ( or box ) 's four LED lights indicated that its already connected to my ISP ( Sympatico Internet Provider ) and even one of green LED lights called, " enet " [refers to ethercard] indicated it's communicating with laptop's ethernet ... wtf? two possiblities ; ethernet onboard integrated in laptop refuse to talk with linux redhat or linux redhat dont understand it. )

    kk, on my winxp machine .. i used sympatico's cd ( dsl software or driver or something ) to install on it. winxp system instantly recognized ethernet .. then asked me to connect the cat 5 cable line ( rj45 or something ) to dsl modem .. sympatico driver or software i installed on machine .. made winxp sys to recongize the dsl modem .. poof .. connected .. all LED lights are green. now as for laptop, while i was installing redhat linux 8, red hat told me it detected lan ethernet on-board .. want me to add it to device list under network configuration .. i selected yes .. then proceed. now, i tryed to connect cat 5 between laptop's onboard ethernet and dsl modem .. nothing happened. however, dell modem's LED lights ( sys, atm, dsl, enet ) all are set to green ( which indicated its fine and its connected to my ISP but cant get internet thru to eth0 .. just same as redhat cant communicate with eth0 .. something wrong with my ethernet onboard the laptop? but during installation, it was detected? okay .. now plz read the following process i did :

    Ethernet Configuration Device
    ________________

    geneal
    ______

    nickname : eth0
    activate device when computer starts (always fail every time anyway)
    automatically obtain IP address settings with DAILUP
    Hardware : eth0 (3com 3c590/3c595/3c90x/3cx980)

    xDSL Configuration Device
    _________________

    general
    _______

    nickname : sympatico ( my ISP provider )
    activate device when computer starts (after eth0 .. but it also fail every time too)
    automatically obtain IP address etting with dhcp
    provider : sympatico .. username ( login ) and password
    advanced : use synchronous PPP ( i dunno why but it was checked at first place )
    make this connection the default route ( checkedbox)
    hardware : eth0 (3com 3c590/3c595/3c90x/3cx980)

    thats info .. now with console i did ..

    ---------------------------------------------------------------------------

    Code:
    [root@localhost root]# redhat-config-network
    
    [b](selected eth0 [ethernet] under devices tab .. and tried to activate it .. then .. this : )[/b]
    
    Determining IP information for eth0... failed.
    
    [b](selected ppp0 Sympatico xDSL .. activated .. 10 seconds later .. went back to inactive)
    [/b]
    /sbin/adsl-start: line 217:  2672 Terminated              $CONNECT "$@" >/dev/nu
    ll 2>&1
    
    [b](clicked "Edit" on eth0 device and ppp0 .. when ethernet device edit was brought up .. tehres some weird messages going on in the terminal .. this : )[/b]
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_cancelBu
    tton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_deviceNa
    meEntry_insert_text'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_okButton
    _clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_deviceNa
    meEntry_changed'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeAdd
    Button_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeDel
    eteButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeEdi
    tButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    AliasesToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    ProbeButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    MACToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    AliasesToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_ipStatic
    Radio_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_ipAutoma
    ticRadio_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    ProbeButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    MACToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeAdd
    Button_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeDel
    eteButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeEdi
    tButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_ipStatic
    Radio_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_ipAutoma
    ticRadio_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_dialupPa
    sswordEntry_changed'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_dialupLo
    ginNameEntry_activate'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeAdd
    Button_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeDel
    eteButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_routeEdi
    tButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    AliasesToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    ProbeButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    MACToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    AliasesToggle_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_ipStatic
    Radio_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_ipAutoma
    ticRadio_toggled'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    ProbeButton_clicked'
    
    
    ** (redhat-config-network:2555): WARNING **: could not find handler `on_hardware
    MACToggle_toggled'
    
    [root@localhost root]#
    --------------------------------------------------------------

    hmm, imaybe redhat linux system on my laptop still didnt know i have dsl modem connected to eth0 ..

    as for complete info .. here

    Code:
    [root@localhost root]# /sbin/ifconfig -a
    
    eth0      Link encap:Ethernet  HWaddr 00:08:74:04:07:61
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:6 errors:1 dropped:0 overruns:0 frame:1
              TX packets:70 errors:0 dropped:0 overruns:0 carrier:7
              collisions:0 txqueuelen:100
              RX bytes:371 (371.0 b)  TX bytes:9597 (9.3 Kb)
              Interrupt:11 Base address:0xec80
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:195 errors:0 dropped:0 overruns:0 frame:0
              TX packets:195 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:14008 (13.6 Kb)  TX bytes:14008 (13.6 Kb)
    
    [root@localhost root]# grep eth0 /etc/modules.conf
    
    alias eth0 3c59x
    
    [root@localhost root]# /sbin/lsmod
    
    Module                  Size  Used by    Not tainted
    nls_cp437               5116   1  (autoclean)
    vfat                   13084   0  (autoclean)
    fat                    38712   0  (autoclean) [vfat]
    nls_iso8859-1           3516   0  (autoclean)
    ide-cd                 33608   0  (autoclean)
    cdrom                  33696   0  (autoclean) [ide-cd]
    i810_audio             25224   0  (autoclean)
    ac97_codec             13384   0  (autoclean) [i810_audio]
    soundcore               6532   2  (autoclean) [i810_audio]
    autofs                 13348   0  (autoclean) (unused)
    ds                      8712   2
    yenta_socket           12960   2
    pcmcia_core            54784   0  [ds yenta_socket]
    n_hdlc                  8032   0
    ppp_synctty             7936   0
    ppp_async               9440   0  (unused)
    ppp_generic            24380   0  [ppp_synctty ppp_async]
    slhc                    6740   0  [ppp_generic]
    3c59x                  30640   1
    ipt_REJECT              3736   6  (autoclean)
    iptable_filter          2412   1  (autoclean)
    ip_tables              14936   2  [ipt_REJECT iptable_filter]
    ohci1394               20108   0  (unused)
    ieee1394               46892   0  [ohci1394]
    mousedev                5524   1
    keybdev                 2976   0  (unused)
    hid                    22244   0  (unused)
    input                   5888   0  [mousedev keybdev hid]
    usb-uhci               26188   0  (unused)
    usbcore                77024   1  [hid usb-uhci]
    ext3                   70368   2
    jbd                    52212   2  [ext3]
    [root@localhost root]#
    [/code]

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, Linux has indeed identified your network card and set it up and all. It's just that it can't retrieve an IP address or otherwise communicate with the peer node.

    I'm guessing that the problem is that your ISP uses PPPoE. I'm not sure if RedHat 8 shipped with PPPoE support (speaking of which - why did you choose RH8 over RH9 or Fedora Core 1?), but if it did, you should be able to run the `adsl-setup' command to set it up properly.

  7. #6
    Just Joined!
    Join Date
    Feb 2004
    Posts
    10


    Code:
    [root@localhost root]# adsl-setup
    Welcome to the ADSL client setup.  First, I will run some checks on
    your system to make sure the PPPoE client is installed properly...
    
    The following DSL config was found on your system:
    
      Device:      Name:
      ppp0
    
    Please enter the device if you want to configure the present DSL config
    (default ppp0) or enter 'n' if you want to create a new one: n
    
    LOGIN NAME
    
    Enter your Login Name: ********
    
    INTERFACE
    
    Enter the Ethernet interface connected to the ADSL modem
    For Solaris, this is likely to be something like /dev/hme0.
    For Linux, it will be ethX, where 'X' is a number.
    (default eth0): eth0
    
    Do you want the link to come up on demand, or stay up continuously?
    If you want it to come up on demand, enter the idle time in seconds
    after which the link should be dropped.  If you want the link to
    stay up permanently, enter 'no' (two letters, lower-case.)
    NOTE: Demand-activated links do not interact well with dynamic IP
    addresses.  You may have some problems with demand-activated links.
    Enter the demand value (default no): no
    
    DNS
    
    Please enter the IP address of your ISP's primary DNS server.
    If your ISP claims that 'the server will provide dynamic DNS addresses',
    enter 'server' (all lower-case) here.
    If you just press enter, I will assume you know what you are
    doing and not modify your DNS setup.
    Enter the DNS information here: server
    
    PASSWORD
    
    Please enter your Password: ********
    Please re-enter your Password: ********
    
    USERCTRL
    
    Please enter 'yes' (two letters, lower-case.) if you want to allow
    normal user to start or stop DSL connection (default yes): yes
    
    FIREWALLING
    
    Please choose the firewall rules to use.  Note that these rules are
    very basic.  You are strongly encouraged to use a more sophisticated
    firewall setup; however, these will provide basic security.  If you
    are running any servers on your machine, you must choose 'NONE' and
    set up firewalling yourself.  Otherwise, the firewall rules will deny
    access to all standard servers like Web, e-mail, ftp, etc.  If you
    are using SSH, the rules will block outgoing SSH connections which
    allocate a privileged source port.
    
    The firewall choices are:
    0 - NONE: This script will not set any firewall rules.  You are responsible
              for ensuring the security of your machine.  You are STRONGLY
              recommended to use some kind of firewall rules.
    1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
    2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
                    for a LAN
    Choose a type of firewall (0-2): 0
    
    Start this connection at boot time
    
    Do you want to start this connection at boot time?
    Please enter no or yes (default no):no
    
    ** Summary of what you entered **
    
    Ethernet Interface: eth0
    User name:  ********
    Activate-on-demand: No
    DNS addresses:      Supplied by ISP's server
    Firewalling:        NONE
    User Control:       yes
    Accept these settings and adjust configuration files (y/n)? y
    Adjusting /etc/sysconfig/network-scripts/ifcfg-ppp1
    Adjusting /etc/ppp/chap-secrets and /etc/ppp/pap-secrets
      (But first backing it up to /etc/ppp/chap-secrets.bak)
      (But first backing it up to /etc/ppp/pap-secrets.bak)
    
    
    
    Congratulations, it should be all set up!
    
    Type '/sbin/ifup ppp1' to bring up your xDSL link and '/sbin/ifdown ppp1'
    to bring it down.
    Type '/sbin/adsl-status /etc/sysconfig/network-scripts/ifcfg-ppp1'
    to see the link status.
    
    [root@localhost root]# /sbin/ifup ppp1
    /sbin/adsl-start: line 217:  3363 Terminated              $CONNECT "$@" >/dev/nu
    ll 2>&1
    [root@localhost root]# /etc/sysconfig/network-scripts/ifcfg-ppp1
    bash: /etc/sysconfig/network-scripts/ifcfg-ppp1: Permission denied
    [root@localhost root]#

  8. #7
    Just Joined!
    Join Date
    Feb 2004
    Posts
    10
    http://www.efficient.com/subscriber_...support.shtml#

    according to that web site, no driver is required for my dsl modem ( Efficient Networks, Inc. SpeedStream 5260 ) and it says all operation systems are supported. /shrug .. think its damn rh8 .. thats having plm wif teh dsl connection or eth0.. think ima dl fedora 1 ? if so, could you give me a link to dl wsite or ftpsite. oh and im still newbie so could u pls explain how to install it on redhat by thru shell cmd ( or console or whatever u like to call it ) if so, i gotta dl fedora from on this winxp machine then imma burn it to cd-r disk .. mount up and install it on rh8 machine. ( i apologize if u guys think im bugging u a bit too much .. ;p )

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I think that you're right about it being RH8. PPPoE support was still rather new when RH8 was released, so it may well be that it's buggy. I'd suggest just what you said: try FC1 instead. You can get it from http://fedora.redhat.com/.
    To install it, just do as you did with RH8 - boot from the CD and let it overwrite RH8. That's probably the smoothest way to do it.

    Don't worry about bugging us - we wouldn't be here if we didn't want to answer questions, after all. =)

  10. #9
    Just Joined!
    Join Date
    Feb 2004
    Posts
    10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •