Find the answer to your Linux question:
Results 1 to 8 of 8
Hi peeps Not being a linux guru i would like to ask some of the more experienced a question ......... System: Shuttle AV40v12 Motherboard (onboard RAID + Sound) Celeron 2.4 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4

    Installation troubles RH9 or Slackware


    Hi peeps

    Not being a linux guru i would like to ask some of the more experienced a question .........

    System:
    Shuttle AV40v12 Motherboard (onboard RAID + Sound)
    Celeron 2.4
    256 PC2100 DDR
    old atapi cdrom
    5gig maxtor hd (or 12 gig fireball)
    (edit: nearly forgot then .. i have no floppy drive in system)

    now then,,,

    Tried installing Redhat 9 ...
    CD refuses to go into install,
    error goes as such:
    RAMDISK: Compressed image fount at block 0
    crc errorfreeing initrd memory: 2640k freed
    VFS cannot open root device " " or 48:05
    Please append a correct "root=" boot option
    Kernel Panic: VFS: Unable to mount root fs on 48:05

    Tried installing Slackware ...
    CD goes through install, and when finished reboot required,
    grrrrrr bombout again..
    Error goes as such:
    kmod:failed to exec /sbin/modprobe -s-k block-major-3 errno2
    vfs: Cannot open root device "302" or 03:02
    please append a correct "root=" boot option
    Kernel Panic: VFS: Unable to mount root fs on 03:02


    Now comes the fun ........

    This i have swapped so far::

    Changed memory,
    Changed Hard drive,
    Changed from IDE channel to RAID and back,
    Tried turning as much off in bios as poss,

    and still i get exact same erros .....

    Can someone tell me what i am doing wrong here please ?

    Any suggestions apprecieted ta.

  2. #2
    Linux Newbie
    Join Date
    Feb 2004
    Location
    India
    Posts
    132
    Hi,
    Can you try ide=nodma when the boot prompt of redhat installer is seen.

    boot: linux ide=nodma

    Tell me if this works.
    You are the one Linux!

  3. #3
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    I think this has to do with the old atapi cdrom in your system.
    If you install slackware then reboot, enter bios and turn it off.
    Does it still crash ?

    Memory isn't the problem. It's the IDE and HD/CDROM that's giving the probs.
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The RedHat error seems like a misburn or bad CD-ROM reader to me, seeing that the ramdisk has a bad CRC. Considering you said that your CD-ROM was old, that might be it.

    I can't really explain the Slackware error, though... Apparently it has no IDE driver (block-major-3 is the primary IDE bus, and erro 2 is No such file or directory), and they haven't shipped an IDE driver either, which just seems really strange to me. Why would a distro ship a kernel without IDE support and no IDE module?

  5. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    Just tested the disks in another machine, same error i am afraid ...

    Stupid bad burn or download
    That'll teach me to check them i suppose

    Thanks for all your help, will let you know when i got it working

  6. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4
    Just FYI ...

    Definately bad disk, i found an old Gentus linux disk lying around and am installing it now

    Thanks again for all your help

  7. #7
    Just Joined!
    Join Date
    Mar 2004
    Posts
    4


    RH9 running at last ....

    Downloaded myself a new CD1 this afternoon, install was up in no time, checked all media before continuing install....

    WooWoo didnt have to buy any new hardware at all, heheh nice

    now to attempt 54g wireless networking (uhoh)

    Only real dissapointment is that i have to now install (i think it said) 138 updates, O well, what do i expect for free

    Cheers again peeps

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, then again, if you had installed Windoze, there would probably be about 500 updates waiting for ya (only that they would be put together in one or two service packs for the sole purpose of not seeming to be so many).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •