Find the answer to your Linux question:
Results 1 to 3 of 3
I have a few questions... 1) When logged in as a regular user, why can I now use ssh? When I use command: ssh 192.168.1.101 I get response that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2004
    Posts
    139

    A few questions from an experienced noob


    I have a few questions...

    1) When logged in as a regular user, why can I now use ssh? When I use command: ssh 192.168.1.101 I get response that I am not permitted to use ssh. I am running Mandrake 9.2 and in the Control Center, I set the security level to higher. Would that security level be the problem for some sort of security? If so, without lowering it, is there any way I can set it so all users can use ssh?

    2) On the desktop, there is CD-ROM, CD-ROM2, and Floppy. I am guessing that these are automatically mounted when booting up. I can access them in a console as root, going to /mnt/cdrom (or whatever device) without a problem, but when I try to access them in the console as a user, I get permission denied. I also get an error when clicking on the icons on my desktop. It opens up Konqueror and then gives me error message that the file or directory /mnt/cdrom does not exist, although there is a CD in the drive. Again, would this be because of the "Higher" security level or is this from that good ol' disease called stupidity?

    Any help is greatly appreciated!

    BTW...I am using Mandrake 9.2 (2.4.22-26mdk) in KDE 3.1.
    If you love something, emerge it

  2. #2
    Just Joined! linduxed's Avatar
    Join Date
    Aug 2003
    Location
    Sweden, Järfälla
    Posts
    87
    Question 1: i'm not familiar with ssh (although i know what it's all about) but as far as i can tell it's a, what i would call, "partial authority" problem.
    the regular user may have got rights to use the application ssh but he is'nt allowed to access other specific parts of the system.
    in your case i guess it's that simple that the regular user is allowed to run the app but hasn't got the privilegies of "plunging into the system of networking", so to say...
    that's the cause although i can't tell what you should do too fix it.

    Question 2: this one may be because of the "higher" setting.
    i think it could easily be solved by editing your /etc/fstab file.
    if you log in as root and open fstab in emacs or something you should just add the option "user" in the options collumn for both cdroms.
    (the option collumn is the one where you find things like "auto", "ro", "noauto" and some other stuff).

    hope that helps!

  3. #3
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Well explained linduxed at least someone takes it in Its nice to see people try and help when there not 100% sure it helps with the mindset. (like me Yeh if you add the user option to your fstab it will let all users access the device.
    And the second question i would guess that you are trying to access an invalid user are you trying to ssh in as root?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •