Find the answer to your Linux question:
Results 1 to 7 of 7
I'm a newbie when it comes to TCP/IP and I have a question regarding this matter. Hopefully an expert will decide to help me on this matter. I have two ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    DNS server/Networking


    I'm a newbie when it comes to TCP/IP and I have a question regarding this matter. Hopefully an expert will decide to help me on this matter.
    I have two machines at home, one is a Windows2000 and the other is running debian linux/windows 2000(dual). It is networked by a linksys cable router. When I installed debian, I used static ip addressing due to serving files and port forwarding. At this time, it asked me the DNS name but I left it blank fearing that if I wrote an ip, i might somehow mess with the router's DNS info. Since the router sets up a network, if I installed a DNS server on my debian machine, will that conflict in anyway with the router? The router holds info of the cable company including the DNS. Furthermore, what is the name of the DNS server that I need to install?
    As always, all help is greatly appreciated.
    The best things in life are free.

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    You will need to add your carriers dns servers into debian. Your router does have that dns info but it only assigns it to your box if you use dhcp to obtain an ip.

  3. #3
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    DNS

    Genlee,

    I added this new first line to /etc/resolv.conf
    Code:
    search www.rr.com\000
    nameserver 24.29.99.218
    nameserver 24.29.99.82
    nameserver 24.29.99.81
    This still doesn't take care of the problem I'm having with apache. I get this error when I start apache
    Code:
    [root@parker sbin]# apachectl start
    [Wed Mar  5 17:05:59 2003] [alert] apache: Could not determine the server's fully qualified domain name, using 192.168.1.2 for ServerName
    /usr/sbin/apachectl start: httpd started
    The best things in life are free.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    You need to set a hostname for your box and add that hostname to /etc/hosts

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You should remove the "search" line from resolv.conf. I do not think you have any use for it.
    The cause of the problem you're having with apache is that you haven't put your public host name in your apache config file. You can fix that by editing /etc/httpd/conf/apache.conf and setting the "ServerName" setting to a host name (or IP address) that is accessible from the internet. It's used for server-side generated redirections. For example, if someone tries to access /dolda on your server, and /dolda is really a directory, apache will redirect the client to /dolda/. That doesn't seem like a problem, but alas, the HTTP specification does not permit redirections with relative URLs, so it must prepend http:// and ServerName to /dolda/, to make it an absolute URL. As you can see, ServerName defaulted to 192.168.0.2, which would mean that apache would redirect the client to http://192.168.0.2/dolda/, which obviously wouldn't work.

  7. #6
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Genlee,

    What's the program name for host serving? The machine name 'parker' is in /etc/hosts.
    The best things in life are free.

  8. #7
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Host servering as in dns servers? That would be bind. Make sure you have your hostname set to parker and your servername in apache set to that as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •