Find the answer to your Linux question:
Results 1 to 6 of 6
Hi! I use redhat linux 8 and set it up as a samba server for win98 to access. When the samba server is setup,the win98 pc can see the linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Posts
    25

    Windows cannot access Linux pc


    Hi!
    I use redhat linux 8 and set it up as a samba server for win98 to access.
    When the samba server is setup,the win98 pc can see the linux computer (the linux computer's name is Manutd) in network neighbourhood. But when i clicked on the icon, a message box appeared. Its contents are: Enter network password
    Resource: \\MANUTD\PC$
    Password:

    I typed different passwords ( win98 password,linux root password,linux user password) but to no avail. Hence, i rightclicked on the linux computer icon and the message 'The server \\Manutd does not accept remote requests' appeared.

    Then I rightclicked on the linux computer icon and clicked properties. I clicked on the Netwatcher button in the properties window and the message ' The computer \\MANUTD is configured for userlevel security and cannot be administered from this share level computer.' appeared.

    The changes I made to smb.conf in the linux pc is as follows:
    Under the [global] section:
    workgroup = ONG ( My windows network workgroup is ONG)
    hosts allow = 192.168.1.2 (The ip add of the win98 pc)
    guest account= pcguest
    security=user
    password level=10
    username level=20
    ;encrypt passwords=yes

    May I know what password to type? (I didn't set any passwords when setting up samba) or even better, is there a way to get rid of the network password dialog box? (should I comment out the security=user line?)

    Please reply quickly if you can.....thanks!!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That's a problem. The thing with Win9x is that they aremeant to be single-user systems, unlike Linux. Now, Microsoft has really taken that one step too far, which means that the username that they will send to the Samba server cannot be anything else than the name with which you logged in to Windows with. Either, log in to Windows with the same username as you use on your Linux box (preferred), create a user on the Linux box with the same name as the one you use on Windows, or create a Samba user name mapping.
    Also, you will have to add that user and its password to Samba's password database. I've written more about that in this thread.

  3. #3
    Just Joined!
    Join Date
    Jan 2003
    Posts
    22
    Quote Originally Posted by Dolda2000
    That's a problem. The thing with Win9x is that they aremeant to be single-user systems, unlike Linux. Now, Microsoft has really taken that one step too far, which means that the username that they will send to the Samba server cannot be anything else than the name with which you logged in to Windows with. Either, log in to Windows with the same username as you use on your Linux box (preferred), create a user on the Linux box with the same name as the one you use on Windows, or create a Samba user name mapping.
    Also, you will have to add that user and its password to Samba's password database. I've written more about that in this thread.
    well at first i had a problem which was quite simular and google'd a bit and found this script that made the passwordfile for samba. after ran the script everything worked perfectly...

    here is the link to the script http://users.pandora.be/bartendavidg...mksmbpasswd.sh

    and these are the commands that you have to use (with your own path's off course):
    su
    mv mksmbpasswd.sh /usr/sbin/
    cd /usr/sbin
    chmod 740 mksmbpasswd.sh
    cat /etc/passwd | mksmbpasswd.sh > smbpasswd

    i worked for me so i hope it helps ...

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    My first look on that script tells me that it cannot possibly work. At least not with my samba version, and I never think the smbpasswd file has looked like that. It also creates passwords for a disabled account, so that way you won't be able to use them anyway. (Then also, you should really run "mksmbpasswd.sh </etc/passwd >/etc/samba/smbpasswd", and it seems better to chmod it to 755, but that wasn't my main point.)

  5. #5
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    smbpassword script

    I've got samba running as a PDC on Redhat 8.

    Create users first using the users and groups GUI.
    make sure that you create a user for each windows user (remember no spaces)
    Then setup the users map file to map the windows usernames to linux ones - if you have used spaces and other strange non linux compatible usernames.

    Then run the script file. You don't need to CAT you just run the file and tell it where the smbpasswd file is to be stored. Check out the smb howto at http://www.tldp.org

    I also found it best to edit the existing smb.conf file as samba is automatically installed on RH8 with PAM and a host of other stuff pre configured.

    once you have run the script file you just need to set passwords for the users in the smbpasswd file.
    smbpasswd -U username
    then enter new password.

    Just in case the users are disabled you might want to enable them as well.
    smbpasswd username -E or something like that.

    I also enabled WINS support but just coz it sounded like a good idea.

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You don't need the script file. Just run "smbpasswd -a username" instead of "smbpasswd -U username".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •