Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
i have php-4.0.x installed now i want to upgrade it to php-4.1x how can i do it.. plz help...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Posts
    36

    upgrading php


    i have php-4.0.x installed now i want to upgrade it to php-4.1x how can i do it..
    plz help

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    What distro?

  3. #3
    Just Joined!
    Join Date
    Mar 2003
    Posts
    36
    Quote Originally Posted by genlee
    What distro?
    i cant understand 'distro'.
    i have a script for music library and it requires php 4.1.x or greater, due to change in enviornment variables. that y i want to upgrade it ..

  4. #4
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    What distrobution of linux do you have installed?

  5. #5
    Just Joined!
    Join Date
    Mar 2003
    Posts
    36
    Quote Originally Posted by genlee
    What distrobution of linux do you have installed?
    linux 7.2

  6. #6
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    I'll take a guess and say you have redhat. Run this command:
    Code:
    rpm -Uvh ftp://rpmfind.net/linux/contrib/libc6/i386/php-4.3.1-1.i386.rpm

  7. #7
    Just Joined!
    Join Date
    Mar 2003
    Posts
    36
    Quote Originally Posted by genlee
    I'll take a guess and say you have redhat. Run this command:
    Code:
    rpm -Uvh ftp://rpmfind.net/linux/contrib/libc6/i386/php-4.3.1-1.i386.rpm
    thanks alot....

  8. #8
    Just Joined!
    Join Date
    Mar 2003
    Posts
    36
    Quote Originally Posted by linuxguru
    Quote Originally Posted by genlee
    I'll take a guess and say you have redhat. Run this command:
    Code:
    rpm -Uvh ftp://rpmfind.net/linux/contrib/libc6/i386/php-4.3.1-1.i386.rpm
    thanks alot....
    i tried but i got messageerror: failed dependencies:
    libcurl.so.2 is needed by php-4.3.1-1
    php = 4.0.6-7 is needed by php-imap-4.0.6-7
    php = 4.0.6-7 is needed by php-ldap-4.0.6-7
    php = 4.0.6-7 is needed by php-mysql-4.0.6-7
    php = 4.0.6-7 is needed by php-odbc-4.0.6-7

  9. #9
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Go to rpmfind.net and install all the deps you that you need.

  10. #10
    Just Joined!
    Join Date
    Mar 2003
    Posts
    36
    Quote Originally Posted by genlee
    Go to rpmfind.net and install all the deps you that you need.
    when i try to install dependent package php-imap i got this messageerror: failed dependencies:
    php = 4.3.1-1 is needed by php-imap-4.3.1-1
    its seems to me a deadlock.
    plz help...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •