Find the answer to your Linux question:
Results 1 to 10 of 10
I'm trying to change my external hard drive permissions so that I can write to it as well, every time I try chmod (or going through nautilus) it gives me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    2,003

    External Hard Drive Permission


    I'm trying to change my external hard drive permissions so that I can write to it as well, every time I try chmod (or going through nautilus) it gives me the error of "read-only system file". Any ideas on how to change this? I'm a newbie still so I'll probably need detailed instructions if it requires using the text editors or what not. Thanks



    jmadero

  2. #2
    Just Joined!
    Join Date
    Jul 2007
    Posts
    1

    Fstab

    check your /etc/fstab line that mounts the external drive (possibly /dev/sd?) and ensure that it does not include 'ro' in the "options" column (the 4th column) - if it does unmount the drive, remove the 'ro' and then remount and you should be able to add write access using chmod as you have been.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by jmadero
    I'm trying to change my external hard drive permissions so that I can write to it as well, every time I try chmod (or going through nautilus) it gives me the error of "read-only system file". Any ideas on how to change this? I'm a newbie still so I'll probably need detailed instructions if it requires using the text editors or what not.
    Most Linux Distros do not support NTFS write access out of box. Chmod works for Linux native FileSystems only.

    Post the output of fdisk -l command and contents of /etc/fstab file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    leomburke is correct. In fact, your best bet is to use the mount option 'rw' (read/write), even if 'ro' (readonly) isn't there.

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by Cabhan
    eomburke is correct. In fact, your best bet is to use the mount option 'rw' (read/write), even if 'ro' (readonly) isn't there.
    But if External Hard Disk has NTFS filesystem, rw wont make any difference.
    Setting rw to Partitions having Linux based FIlesystem will enable write access to root user only.
    One has to take ownership of mount_point to have read/write access of Linux based FileSystems.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    2,003

    Not NTFS

    I am fairly sure it's not NTFS. I don't have access to the drive until I get home tonight but I am fairly sure I purposely formatted it as FAT. I'll try the suggestions here....I'm not sure why I would have to unmount it, I have never manually mounted it in this distro, I used to have to in FC3 but now it's basically just plug and play....is it a default to have it as ro?

    jmadero

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    If External Disk has FAT FileSystem then it will default to rw because Fedora support FAT read/write access out of box.
    Check the output of fdisk -l command.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    2,003

    Ntfs

    I checked the hard drive in windows and it was NTFS....I had to do some crazy stuff to partition it, move all the stuff (almost 100 gigs) to the FAT32 partition, then I deleted the first partition and resized the FAT32 partition....the only problem is it wouldn't allow me to make it more than 195 gigs or so, so I have 55 gigs being wasted....but good news is that I can delete and modify files on the drive now and all of my files were saved (at one point I thought I had lost about 10 gigs of music). Thanks all


    jmadero

  10. #9
    Just Joined!
    Join Date
    Apr 2012
    Posts
    1

    The problem with FAT...

    ..is that it has a maximum file size of 1 Gig, so if you want to be able to store larger files (like video files for example), and also be able to swap the drive back and forth between a Windoze system, then you kind of need NTFS I think. So is there a workaround for NTFS?


    Quote Originally Posted by jmadero View Post
    I checked the hard drive in windows and it was NTFS....I had to do some crazy stuff to partition it, move all the stuff (almost 100 gigs) to the FAT32 partition, then I deleted the first partition and resized the FAT32 partition....the only problem is it wouldn't allow me to make it more than 195 gigs or so, so I have 55 gigs being wasted....but good news is that I can delete and modify files on the drive now and all of my files were saved (at one point I thought I had lost about 10 gigs of music). Thanks all


    jmadero

  11. #10
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Guys, this thread is well over 5 years old so I'm going to go ahead and close it, but if any of you are still having issues with Linux, please feel free to start a fresh thread with details.

    Thanks...
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •