Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, Sorry for the long post, it's as much about venting as about asking for help. As one of the myriad Windows users that are trying Linux these days ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    DSL sea of trouble


    Hi all,
    Sorry for the long post, it's as much about venting as about asking for help.
    As one of the myriad Windows users that are trying Linux these days I did successfully pass my two main PCs to Ubuntu Studio and forgot about Windows. The process was pretty painless, i did use the CLI sometimes, the help forums and voilá, a new "Linux expert" is born. Evidently all this made me feel very geeky and high-tech, so I gave up my common sense.
    I decided that my old laptop would be a great digital photo frame, and started doing the appropriate research. It turned out that many people were very cautious about the software side of things, but some guys went all the way to setting up a scripted server with network connections using a prehistoric machine. I forgot about precaution and decided to copy the best, most complicated setup I found.
    The setup I'm trying to build is a box with wifi networking and SSH so that I can admin from my usual setup. My PC is a Pentium Celeron 400mhz. with 64MbRam and 4Gb HD.
    I read about the different distros, tried a few and found out that many of them did not boot. The most promising were DSL 3.3 and Puppy 2.02, the latest versions were more trouble.
    So I chose DSL, it was more "neat" and I was feeling brave at the moment.
    Boy, was I going to be humbled.
    First of all, my wifi gadget is a SMCWUSB-G with a ZD1211 chipset. which means, or so I read, going ndiswrapper, because to have native support you need kernel 2.6.17 and the 2.6.x series will not boot on my PC, don't know why (I have some hint about this, lots and lots of trouble with IRQ:15 and ACPI). I've tried ndiswrapper with different drivers and they all install fine and see the hardware, but they freeze the system when I iwconfig after modprobbing. I also tried to compile the linux drivers but there is no gcc in DSL, only tcc wich evidently, is no easy to use. I thought about installing gcc, but the file I saw online was 50mb. and I could not beleive I needed a file as heavy as the whole operating system just to compile a c program, so I stopped there. I spent two days fighting and reading, reading forums learning how to copy stuff, mount, umount, Midnight Commander, fluxbox, sudo, etc, etc. To no avail. So that lead to my question number 1: Has anyone used ZD1211b gadgets using a 2.4.x kernel? and if yes, how?
    Well, while I was deciding whether to buy a new wifi adapter more "friendly" to DSL or to give another round of reading, I tried to setup the frame without networking, to start having results. I was going to use Feh and unclutter scripted with cron starting and stopping the system.
    Evidently, there is no feh, unclutter or cron installed with DSL, that's what DSL stands for!.
    Another round of reading has left me convinced that having a DSL system online, must be wonderful, everything installs easily.
    I do not have networking, see above.
    So i start reading abour tarballs, tgz, rmp and .dsl. I need .dsl files, I discover. I manage to get feh.dsl and unclutter.dsl, install and run them.
    I have not been able to find cron. So question number 2: How do I install cron offline in DSL?
    So anyways, I pushed on. Feh and unclutter worked, so I started writing the scripts to use them. And then, after two imortant defeats, DSL gave the "coup de grace": I was not able to execute ANY bash script because I got the bash: permission denied error. ****, **** and a lot more ****.
    Question number 3 is if anyone can help with this error, because after reading online it looks daunting to say the least.
    So if I analyze the last week I have been unable to boot 90% of teh distros I tried, I've been unable to get my machine online, I've been unable to install all the packages needed manually and finally I've been unable to execute the most basic script in the shell.
    I've learned a LOT, most of all humility, but I think I need:
    a) lots of help
    b) some more time
    c) a cron.dsl file and a working zd1211b driver

    Again, sorry for the long post.

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    I've dled cron.deb an i'm going to try converting it to .dsl

    If this works, question number 2 is solved!

    Thank you anyway...

    EDIT: I found the myDSL ftp server and I'm downloading the .dsl's I need. It was evident that myDSL packages would work like that, but some of us are slower than others. Question 2 answered, then.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    97
    Wow...sounds like fun...for a digiframe I just installed dsl and added gqview and a folder of pics and set the viewer to auto open the folder..then opened the program and from the menu chose full screen..start slideshow...the second pic hid the cursor so just a screen flickin pics..
    cron was added I think to the newer version but the older versions require the cron.dsl from the repository..I used it to make the frame ( old computer) speak the time on the hour
    anyway have FUN and best of luck

  4. #4
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    Thanks, since I wrote the post thing have been looking up. I was able to get kernel 2.6.17 running so I was able to get Wifi without ndiswrapper.
    I also able to install all the packages needed and make scripts work (chmod 755 everthing and not just a little part).
    Right now I am fighting against SSH (I connect remote into my picture frame but I don't get X).
    The scripts need to be ironed out and the cron scheduler needs some attention, but I'm getting there. Sure, it's going slow but at least there's some sense of progress.
    Overall you're right, I'm having LOTS of fun, since the old DOS days I have not been able to do this level of tweaking and I realize now it was the good way to do things. This way you understand what you do.
    Thanks for the support.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •