Find the answer to your Linux question:
Results 1 to 5 of 5
I have a PS3, Yellow Dog 5.0.2 is installed on it. I have removed the wireless card. Yellow Dog boots fine. I am a known good ethernet cable connected to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    PS3 Yellow Dog Wired Connection not working


    I have a PS3, Yellow Dog 5.0.2 is installed on it.
    I have removed the wireless card.
    Yellow Dog boots fine.
    I am a known good ethernet cable connected to the wired port on the PS3.
    I am able to configure the eth0 to have a valid address.
    However, I can not access the network.

    I am not new to linux and understand how to manually configure the ifcfg-eth0 file for a static ip address. I was wondering if anyone has any ideas what the problem could be.

    When I use the system-config-network utility, a wireless device seems to get configured. I have not idea how.

    Any help would be appreciated.

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15

    Always start off simple

    Are you still having problems connecting with a hardwired connection? First look to see if the connection is getting a Link light. I don't know the PS3 but if it's connected to a switch or a router then it should have Link light. If it's not; then are you using a patch cable or a crossover? I believe a patch cable should be used in this case. If still having problems; try swapping the cable out for one that does work? If that doesn't work; try going to to the command prompt and running this command" ifup eth0" or whatever adapter number it may be? If that doesn't work then perhaps there's a problem with the ethernet adapter. Check to see if activated or recognized by the PS3 hardware.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2
    I do have a link light.
    I am using a patch cable.
    I disconnected another machine and used it't patch cable and network port.
    The previous machine was working over the network for months without a problem.

    I have tried manually bringing up the network using the ifup eht0 command and the eth0 comes up, gets the manually set it address and appears to work fine, however the network connection is not working. I do not get any responses to pings using the ip address ( not the host name). I validated the machine are up and responding to pings from other machines.

    I have booted to the ps3's xmb. It recognizes that I have a wired connection. However it tells me I have a 80010201 error when I try to configure the network (either through dhcp and thru manual setup).

    Any other ideas?

    Thank you
    T

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    15

    Have you tried this aswell?

    Hello Fariast,

    Apologies for the late reply. Busy week(nuff said). Anyways, I do have some further questions and suggestions for you if it's not to much? It does "sound" like your cable connection, router, and internet connection are in working order. I'll assume and trust your analysis since I can't see it. I'll also assume you've also tried changing the cable to different ports on your router ethernet connections.

    While I was looking up your error message; it appears to be very common with the PS3. Lot's of people are struggling with it. I went to this site which had a forum explaining the frustration many of the users had to doing something similar.:

    http://community.eu.playstation.com/...ad.php?t=70652

    And there are so many others out there as well. Since you said the PS3 recognizes the hardware; let's assume it's a software issue. With that said; what's the LAN ip address, subnet mask, and LAN gateway ip address(the router)? Please type for review please( not any of the WAN ip's ). Do you also think their could be device it's in conflict with on your network too?

    Since I'm unfamiliar with the PS3 software; does it allow you reload or upgrade it's OS or firmware(the xmb right?) without difficulty? You may need to do this. If not; then don't bother. You might end up turning that nice piece of hardware into a brick. Question: When did you buy it? Is it still under warranty? This could be a factory defect. If so, then you might have to send it back for a repair. Read at the documentation that came with it to see how Sony deals with these issues to see if it's worth it. I haven't found a clear solution as to what the problem could be but I'm still looking.

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    1

    Found the right driver

    Here's how I got the wired ethernet running under YDL 6:

    From the Network Configuration I removed the en0 device (wireless)
    Added new wired ethernet device as en0
    Selected SysKonnect 98 driver
    left other settings default (dhcp)

    I couldn't find any data on what driver to select by Google so I Googled for an image of a PS 3 motherboard. It's pretty obvious which chip is connected to the ethernet port. Its made by Marvell. I found a reference to a integrated device on the Marvell website and went ahead and downloaded the Linux driver. I then took note of the name of the driver (SK9 and went looking for something similar in the Yellow Dog Linux network configurator.

    SysKonnect according to syskonnect.eu is "a member of the Marvell family..."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •