Find the answer to your Linux question:
Results 1 to 2 of 2
On Centos 4.2 kernel 2.6.9.22 Intermittently during boot, the system will hang on "Enabling Swap Space". This is intermittent however. Sometimes it will happen 5 or 6times in a row, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1

    Hanging on Enabling Swap Space during boot


    On Centos 4.2 kernel 2.6.9.22

    Intermittently during boot, the system will hang on "Enabling Swap Space". This is intermittent however. Sometimes it will happen 5 or 6times in a row, but then it will boot the 7th time without a problem.

    When this happens sometimes, I'll try to boot into single user mode from Grub Boot Loader but for some reason while in the Grub Boot Loader kernel selection screen I cannot enter the 'e', 'a' or 'c' keys. The only key I can enter is 'ENTER' which boots my kernel (only one OS on this box).

    So two questions:

    1. Why is my system hanging on "Enabling Swap Space"?
    2. Why can't I enter single user mode in Grub Boot Loader?

    Thanks

  2. #2
    Linux Enthusiast
    Join Date
    Jul 2005
    Location
    Maryland
    Posts
    522
    1. Why is my system hanging on "Enabling Swap Space"?
    Try to disable extra mounts (check /etc/fstab file) from mounting automatically. For, example, this can happen when the machine is configured to mount network share (Samba) when it boots, but the share is not available, or networking is not up yet or it isn't configured correctly.

    Computer needs to know what it is and where it belongs to on the network. So, hostname, DNS, netmask, default route, and IP, all need to be set correctly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •