Find the answer to your Linux question:
Results 1 to 4 of 4
First of all, sorry I'm a n00b. Secondly, thanks for the help. I'm brand new to linux, and am using freespire, but I have managed to configure my dual boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1

    install problems ./configure...... :(


    First of all, sorry I'm a n00b.

    Secondly, thanks for the help.

    I'm brand new to linux, and am using freespire, but I have managed to configure my dual boot config from one hard drive, and enable the root account....(with a heavy pass, and only for the installation of files)


    I'm trying to install snort. I downloaded the files, and decompressed them, I get into the "Root shell" and follow the instructions for the install.....

    I located the snort file..

    root# cd snort
    root# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    ........ a bunch of lines later........
    checking for pfring.h... no
    checking for pfring_open in -lpfring... no
    checking for pfring_open in -lpcap... no

    ERROR! Libpcap library/headers (libpcap.a (or .so)/pcap.h)
    not found, go get it from http://www.tcpdump.org TCPDUMP public repository
    or use the --with-libpcap-* options, if you have it installed
    in unusual place. Also check if your libpcap depends on another
    shared library that may be installed in an unusual place

    I tried looking for solutions, and am not finding them....
    from>ERROR! Libpcap library/headers not found, Help installing SNORT on CentOS - Snort Forums Archive
    ERROR! Libpcap library/headers not found, Help installing SNORT on CentOS - Snort Forums Archive[/url]

    I Tried this:
    wget http://isoredirect.centos.org/centos...4-8.1.i386.rpm
    rpm -ivh libpcap-devel-0.9.4-8.1.i386.rpm

    Results:
    warning: libpcap-devel-0.9.4-8.1.i386.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
    error: Failed dependencies:
    libpcap = 14:0.9.4-8.1 is needed by libpcap-devel-0.9.4-8.1.i386
    libpcap.so.0.9.4 is needed by libpcap-devel-0.9.4-8.1.i386

    I'm kind of at a loss, and I'm guessing that i'm totally off, but it seems that I need some libraries that I don't have. hahah, Thanks again for your help.

    -confidentbeginner

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    9
    Before installing the libpcap-devel-0.9.4-8.1.i386.rpm you have to install the
    libpcap-0.9.4-8.1.i386.rpm.....

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Why and how are you using .rpm's on a Debian based distro? Does *spire have that capability??
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #4
    Linux User
    Join Date
    Jun 2007
    Posts
    458
    Sorry newbie, *spire is a derivative of Ubuntu and is capable of .deb(ian)s and not .rpm (RedHat Package Manager)s. You can get the software from a Linspire repository. You must look into it by googling it up. I am sorry, haven't used any debian based distro and cannot help you.
    "When you have nothing to say, say nothing."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •