Find the answer to your Linux question:
Results 1 to 5 of 5
Hi folks, Ubuntu 7.04 server amd64 (Host OS) CentOS-5_lamp.x86_64 (Guest OS) VMWare - Virtualization platform # cat /boot/grub/grub.confp Code: # grub.conf generated by anaconda # # Note that you do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,791

    Some minor problem on booting centOS 5


    Hi folks,


    Ubuntu 7.04 server amd64 (Host OS)
    CentOS-5_lamp.x86_64 (Guest OS)
    VMWare - Virtualization platform


    # cat /boot/grub/grub.confp
    Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE:  You have a /boot partition.  This means that
    #          all kernel and initrd paths are relative to /boot/, eg.
    #          root (hd0,0)
    #          kernel /vmlinuz-version ro root=/dev/sda3
    #          initrd /initrd-version.img
    #boot=/dev/sda
    default=1
    timeout=5
    splashimage=(hd0,0)/grub/splash.xpm.gz
    #hiddenmenu
    title CentOS (2.6.18-53.1.4.el5)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.18-53.1.4.el5 ro root=LABEL=/ rhgb quiet
    	initrd /initrd-2.6.18-53.1.4.el5.img
    title CentOS (2.6.18-8.1.15.el5vm)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.18-8.1.15.el5vm ro root=LABEL=/ rhgb quiet
    	initrd /initrd-2.6.18-8.1.15.el5vm.img
    title CentOS (2.6.18-8.1.15.el5)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.18-8.1.15.el5 ro root=LABEL=/ rhgb quiet
    	initrd /initrd-2.6.18-8.1.15.el5.img

    1)
    On booting it automatically selects "CentOS (2.6.18-8.1.15.el5vm)". I have to manually select "CentOS (2.6.18-53.1.4.el5)" which I suppose is latest version of kernel on CentOS 5.

    Whether I have to change "default=1" to "default=0" to boot kernel "CentOS (2.6.18-53.1.4.el5)" automatically ?


    2)
    On booting kernel "CentOS (2.6.18-53.1.4.el5)" following warning popup on text scrolling
    Code:
    Memory for crash kernel (0x0 to 0x0) notwithin permissible range
    ACPI: Getting cpuindex for acplid 0x1
    ACPI: Getting cpuindex for acplid 0x2
    ACPI: Getting cpuindex for acplid 0x3
    powernow-k8: BIOS error - no PSB or ACPI _PSS objects
    Red Hat nash version 5.1.19.6 starting
    .......
    CentOS 5 starts finally w/o problem


    3)
    On booting kernel "CentOS (2.6.18-8.1.15.el5vm)" following warning popup on text scrolling;
    Code:
    ACPI: Getting cpuindex for acplid 0x1
    ACPI: Getting cpuindex for acplid 0x2
    ACPI: Getting cpuindex for acplid 0x3
    powernow-k8: BIOS error - no PSB or ACPI _PSS objects
    Red Hat nash version 5.1.19.6 starting
    .......
    CentOS 5 starts finally w/o problem


    Please advise how to fix the warning on 2) and 3) abvoe. TIA


    B.R.
    satimis

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    1) title count starts from zero only and title CentOS (2.6.18-53.1.4.el5) is first title ( zero ). Set default value to 0.
    2) 3) Add noacpi parameter at the end of kernel line.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,791
    Quote Originally Posted by devils_casper View Post
    1) title count starts from zero only and title CentOS (2.6.18-53.1.4.el5) is first title ( zero ). Set default value to 0.
    2) 3) Add noacpi parameter at the end of kernel line.
    Thanks for your advice.


    1)
    changing "default=1" as "default-=0"

    Problem solved.


    2)
    # cat /boot/grub/grub.confp
    Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE:  You have a /boot partition.  This means that
    #          all kernel and initrd paths are relative to /boot/, eg.
    #          root (hd0,0)
    #          kernel /vmlinuz-version ro root=/dev/sda3
    #          initrd /initrd-version.img
    #boot=/dev/sda
    default=1
    timeout=5
    splashimage=(hd0,0)/grub/splash.xpm.gz
    #hiddenmenu
    title CentOS (2.6.18-53.1.4.el5)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.18-53.1.4.el5 ro root=LABEL=/ rhgb quiet noacpi
    	initrd /initrd-2.6.18-53.1.4.el5.img
    title CentOS (2.6.18-8.1.15.el5vm)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.18-8.1.15.el5vm ro root=LABEL=/ rhgb quiet noacpi
    	initrd /initrd-2.6.18-8.1.15.el5vm.img
    title CentOS (2.6.18-8.1.15.el5)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.18-8.1.15.el5 ro root=LABEL=/ rhgb quiet noacpi
    	initrd /initrd-2.6.18-8.1.15.el5.img
    Problem still remains

    Warning
    Code:
    Memory for crash kernel (0x0 to 0x0) notwithin permissible range
    ACPI: Getting cpuindex for acplid 0x1
    ACPI: Getting cpuindex for acplid 0x2
    ACPI: Getting cpuindex for acplid 0x3
    powernow-k8: BIOS error - no PSB or ACPI _PSS objects
    Red Hat nash version 5.1.19.6 starting
    .......

    3)
    I'll leave this old kernel alone

    satimis

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !

    I checked CentOS Manual and this is listed in Known Issues section.
    Quote Originally Posted by CentOS Manual
    During the boot process you may see the message "Memory for crash kernel (0x0 to 0x0) not within permissible range" appear. This message comes from the new kdump infrastructure. It is a harmless message and can be safely ignored.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by Gentoo Wiki
    If you get an error like this:
    Code:
    powernow-k8: BIOS error - no PSB or ACPI _PSS objects
    Then probably you don't have the Cool'n'Quiet enabled in the BIOS. People have also reported that they get the same error even if the option is set correctly. You should ensure your BIOS has support for the feature, since the linux driver needs frequency tables (PSB) or ACPI methods (_PSS) to work. Then try if upgrading your BIOS solves the issue. If you have this error, make sure that you have ACPI Processor support enabled in your kernel, the non-ACPI ways is disabled on SMP bioses (including those that support X2 processors) and deprecated by AMD.
    Gentoo Wiki.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •