Find the answer to your Linux question:
Results 1 to 4 of 4
I'm not completely new to linux, I use it in school everyday, but I just installed CentOS 5.1 on my personal computer for the first time and I am having ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4

    CentOS - NIC driver installation trouble


    I'm not completely new to linux, I use it in school everyday, but I just installed CentOS 5.1 on my personal computer for the first time and I am having a lot of trouble figuring out how to get my network cards (Wired: Realtek 8101 and Wireless: Intel 4965 AGN) to work.

    System->Administration->Network->Hardware shows nothing
    System->Administration->Hardware->Network Devices shows the wireless card but not the wired

    I figured I need to install the drivers. I got linux drivers from the manufacturers sites, followed all of the readme and installation tips and nothing seems to work.

    Wired driver: r8101-1.006.00.tar.bz2
    Wireless driver: iwlwifi-1.2.23.tgz
    iwlwifi-4965-ucode-4.44.17.tgz


    any help would be GREATLY appreciated, thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4

    a little further now...

    Ok I got the wired realtek driver to install and appear in hardware menu. In the network menu an item appeared but it is the wireless card configured as ethernet not wireless. when i do an ifconfig eth0 now comes up with the realtek MAC but in the network menu it is titled as the wireless nic, could this just be a gui error?

    please anyone if you can offer any advice at all it would be great

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4

    centos version?

    could someone please tell what the command in centos 5.1 is that will do the same as:

    sudo apt-get install build-essential linux-headers-$(uname -r)

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4

    wireless -- modprobe iwl4965

    well i got the realtek installed and working...but now i am moving on to my wireless. I am following an ubuntu step-by-step here: zoltan's blog: How to install Intel iwlwifi 4965AGN wireless drivers on Ubuntu

    i get as far as copying the file into /lib/firmware and when i try to issue the next command, `modprobe iwl4965` the teminal pauses for a few seconds and the system reboots.

    is their something i am forgeting? something that cent does differently than ubuntu? please help if you can, any advice would be great. Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •