Find the answer to your Linux question:
Results 1 to 6 of 6
I'm trying to build fontconfig-2.3.2. I've run ./configure, and it worked fine. Now I run make and it gives me this error: Code: In file included from ../src/fcint.h:39, from fc-case.c:25: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    17

    CentOS - Include Problems


    I'm trying to build fontconfig-2.3.2. I've run ./configure, and it worked fine. Now I run make and it gives me this error:
    Code:
    In file included from ../src/fcint.h:39,
                     from fc-case.c:25:
    ../fontconfig/fcfreetype.h:27:22: error: ft2build.h: No such file or directory
    ../fontconfig/fcfreetype.h:28:10: error: #include expects "FILENAME" or <FILENAME>
    I've already built freetype, but I don't have root privileges, so I created a new directory and copied all the necessary include files (ft2build.h) into that directory. Then I run
    Code:
    make -I /home/joha/libraries/include
    but I get the same error. Does anyone know how to fix this? Thanks.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Is there a special need to compile fontconfig from source? It can be installed using yum. If there are special considerations for it to be compiled from source, try installing fontconfig-devel first:
    Code:
    yum install fontconfig-devel
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    17
    Is there a way to use yum without root privileges?

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    If there is, I don't know what it is. You are trying to install a package without being root? That might be the reason you are not able to build the package right there. Can you explain a little more about why you cannot get root privileges? I've never run into this...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    17
    I don't have root privileges because I am not the sysadmin. So instead of installing everything to /usr/bin, etc. I have created new directories in my home directory and am setting my PATH, LD_LIBRARY_PATH, etc. to include those directories. Or I'm trying to at least. It worked for freetype. It's just not working for fontconfig.

    I've got my path and library path set up. Now I just need to get make to use the includes from my new directory.

  6. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    As I said, there may be a way to do what you are wanting. If there is, I don't know it. Sorry I couldn't help. Good luck.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •