Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 37

Thread: CRUX Install

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21

    Why don't you switch to 2.4? That's just a friendly question, nothing to do with tech. Do you suppose you could use your own kernel with that? If yes, then installation is less than 10 minutes! Packages install within 5 minutes and copying the kernel is no problem!

  2. #22
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,634
    I will eventually. It's just that 2.3 is working so well for me at the moment I don't want to fix it if it ain't broke. By the way, I tried yet again last night to build Gnome and succeeded! This time I got really brave and pulled all the stops, telling it to ignore mismatched footprints and mismatched md5sums. I also used the force option. So far so good! I'll have a CRUX-Gnome screen shot up soon! If you are interested in Gnome and want to give it a go:
    Code:
    prt-get depinst -f -if -im --install-scripts gnome
    Warning: The documentation recommends installing ports without using the force option and only using it as a last resort. As I couldn't get a decent Gnome desktop any other way, I felt for me it was a last resort.

    I still use IceWM 95% of the time, but like to have a viable KDE and Gnome desktop around to be better prepared to advise new users on problems they may be having with either.
    Last edited by Dapper Dan; 02-15-2008 at 06:25 PM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #23
    Now for some more trouble:

    1) / is mounting read-only;
    2) GUI does not show;

    Here's my fstab entry:
    Code:
    # /dev/sda9 UUID=fdcbaa10-a119-44ed-969b-9ab4f9e918c7   /    reiserfs  defaults,errors=remount-ro   0    1
    And here's my GRUB entry foor CRUX:
    Code:
    title           CRUX 2.4
    root            (hd0,8)
    kernel  /vmlinuz root=/dev/hda9
    quiet
    ?

  4. $spacer_open
    $spacer_close
  5. #24
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,089
    You asked earlier in this thread for removal of the UUID entries ... I commented out the UUID line and put the corresponding line below incase it helps
    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda8
    #UUID=5699b544-f68c-4b62-b98f-502584c6ff4d /               ext3    defaults,errors=remount-ro 0       1
    /dev/sda8 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/sda1
    #UUID=786B-C5BE  /media/sda1     vfat    defaults,utf8,umask=007,gid=46 0       1
    /dev/sda1  /media/sda1     vfat    defaults,utf8,umask=007,gid=46 0       1
    # /dev/sda5
    #UUID=C0EB-F85E  /media/sda5     vfat    defaults,utf8,umask=007,gid=46 0       1
    /dev/sda5  /media/sda5     vfat    defaults,utf8,umask=007,gid=46 0       1
    # /dev/sda7http://www.tuxfiles.org/linuxhelp/fstab.html
    #UUID=A4FD-8079  /media/sda7     vfat    defaults,utf8,umask=007,gid=46 0       1
    /dev/sda7  /media/sda7     vfat    defaults,utf8,umask=007,gid=46 0       1
    # /dev/sda3
    #UUID=07ea4d4b-211f-4f8e-8e08-9f924b41fafc none            swap    sw              0       0
    /dev/sda3 none            swap    sw              0       0
    # /dev/sda6
    #UUID=3f74ff33-801b-405b-bef2-59dc7508abe6 none            swap    sw              0       0
    /dev/sda6 none            swap    sw              0       0
    /dev/scd0       /media/cdrom   udf,iso9660 user,noauto,exec 0       0
    /dev/fd0        /media/floppy  auto    rw,user,noauto,exec 0       0
    Anyway the post you provided started with the # so will be treated as a comment (unless its lost something when you pasted the code). I suggest you post the output of fdisk -l and full contents of /etc/fstab if you need further help so we can be clear about partitions and file systems on each partition.

    You might also find this useful.

  6. #25

    Root Mounting Read Only

    Anyone willing to help me with these problems: click here ( ^ )
    Last edited by Tsarevich; 02-17-2008 at 05:56 PM. Reason: Broken Link

  7. #26
    Jonathan: Here's my fdisk -l output:

    Code:
    root@toshiba:~# fdisk -l
    
    Disk /dev/sda: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xfc07fc07
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        1275    10241406    c  W95 FAT32 (LBA)
    /dev/sda2            1276        4864    28828642+   f  W95 Ext'd (LBA)
    /dev/sda3            4865        4865        8032+  82  Linux swap / Solaris
    /dev/sda5            1276        2550    10241406    b  W95 FAT32
    /dev/sda6            3793        3825      265041   82  Linux swap / Solaris
    /dev/sda7            3826        4864     8345736    b  W95 FAT32
    /dev/sda8            2551        3171     4988151   83  Linux
    /dev/sda9            3172        3792     4988151   83  Linux
    
    Partition table entries are not in disk order
    root@toshiba:~#
    Thanks for the piece of information, but I do not need further help in this case.

    Dapper Dan: Please help me because root is mounting read-only always.

  8. #27
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,634
    I've not kept up with the changes to 2.4 so I'm ill at ease to advise you, other than to say my root partition in 2.3 is mounted simply with the option, "defaults." Check back to my fstab earlier in this thread to see. You could try that, but be be sure to be able to edit it back the way it was if this doesn't work in 2.4. Slackware root partition is mounted read only too. After boot up, are you able to edit files in your root partition after becoming su? What problems are you attributing to your root partition being mounted read only?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #28
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,089
    OK I will work on the basis your root is on sda9 (based on fdisk -l output & your previous posts). I think you need to modify the default fstab to this ...
    Code:
    # /etc/fstab: static file system information
    #
    # <file system>        <dir>     <type>    <options>              <dump> <pass>
    
    /dev/sda9  /         reiserfs  defaults               0      0
    #/dev/#EXT3FS_ROOT#    /         ext3      defaults               0      1
    assuming your file system is reiserfs rather than ext3.

    You should also modify your grub file to match sda rather than hda reference ...
    Code:
    title           CRUX 2.4
    root            (hd0,8)
    kernel  /vmlinuz root=/dev/sda9
    quiet
    I tend to use ext3 rather than reiserfs so I would have an fstab with ...
    Code:
    #
    # /etc/fstab: static file system information
    #
    # <file system>        <dir>     <type>    <options>              <dump> <pass>
    
    #/dev/#REISERFS_ROOT#  /         reiserfs  defaults               0      0
    /dev/sda9    /         ext3      defaults               0      1
    I hope this helps.

  10. #29
    I did it!!!!!!!!!!!!!!!!

    File System IS read/write now.

    GRUB should not have sda reference either.

    GRUB entry looks like this:
    Code:
    kernel     (hd0,8)/vmlinuz root=/dev/hda
    And fstab like this:
    Code:
    /dev/hda9   /    reiserfs  defaults   0    1
    At least as of 2.4, its like this.

    But Blackbox does not start with startx command. Just three bashes are dispayed over the screen. With similar output each time.



    NOW WHAT??? (I'm not shouting)

  11. #30
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,634
    Three open terminals in kind of a funky green color? Sounds like twm which was the default for 2.3. So at least it sounds like you have X. To start blackbox, simply type that in one of the terminals and press enter. If it says another wm is already running, try:
    Code:
    blackbox --replace
    If you decide to use kdm or gdm, then blackbox will show up there as a sessions choice. If not and you want to start blackbox from the "startx" command, edit /usr/lib/X11/xinit/xinitrc and change twm (at the bottom) to blackbox.

    Are you going to stay with blackbox or IceWM? If IceWM, do you have an Internet connection yet? You can configure network connection in /etc/rc.d/net. Just open it with your favourite editor and configure for your connection. Then you can either download IceWM from here and install it, or install it with prt-get.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •