Find the answer to your Linux question:
Results 1 to 2 of 2
This is the second time I have started a post similar to this , coz the first time, I could fix it really easily but after recompiling the kernel for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jun 2007
    Posts
    458

    root mounting ReadOnly


    This is the second time I have started a post similar to this , coz the first time, I could fix it really easily but after recompiling the kernel for CRUX 2.4, and reinstalling it, the problem has reappeared.

    Probably a call for Dapper Dan again. But here's my GRUB entry (no change since last install):

    Code:
    title           CRUX 2.4
    root            (hd0,6)
    kernel          /vmlinuz root=/dev/hda7 acpi=force
    quiet
    While here's my fstab entry (same as a working example in Ubuntu except for the sda, we use hda in CRUX):

    Code:
    # /dev/hda7 
    UUID=119abafd-8929-486b-938b-76d8d221c868             /         reiserfs  notail                     0      1
    So anyone?
    "When you have nothing to say, say nothing."

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    If your still struggling with this one I suggest ...
    1. number one candidate is kernel modules/options ... make sure you compiled the kernel with reiser fs read/write support (in the kernel not as a module).
    2. check the output of
    dmesg | grep mount
    dmesg | grep error
    and see if you get any clues about why you have a read only mount
    3. check the uuid you have in fstab is correct.

    Good luck and let us know how things go.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •