Find the answer to your Linux question:
Results 1 to 3 of 3
The application: xmind.jpg (image) The problem: Trying to run Xmind gives a error message from the console, mentioning a log file: Clicking on the "xmind Executable File" (red binary icon), ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86

    [SOLVED] Example how to install and run Xmind on SimplyMEPIS 7.0


    The application:
    xmind.jpg (image)




    The problem:
    Trying to run Xmind gives a error message from the console, mentioning a log file:
    Clicking on the "xmind Executable File" (red binary icon), gives me a small window a message, guiding me to:

    /root/.xmind/Brainy2-i20071004/.metadata

    /.xmind is a hidden file in root.

    .log states:

    !SESSION 2008-08-22 17:43:44.877 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.6.0
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_CH
    Command-line arguments: -os linux -ws gtk -arch x86

    Etc., etc., listing the plugins for runtime, followed by other information, to be followed with a listing of the plugins again, etc., and so on.

    The latest message is relevant: So I scrawl ritght to the bottom:

    The relevant and important message of .log says:



    !ENTRY org.eclipse.osgi 2 0 2008-08-23 09:36:43.269
    !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2008-08-23 09:36:43.269
    !MESSAGE Bundle update@plugins/org.eclipse.core.runt...mpatibility.nl1_3.1.100.v200609270227/ [20] was not resolved.
    !SUBENTRY 2 org.eclipse.core.runtime.compatibility.nl1 2 0 2008-08-23 09:36:43.269
    !MESSAGE Missing host org.eclipse.core.runtime.compatibility_0.0.0.


    So, this seems to be the problem hindering to run the mind map application "Xmind":

    update@plugins/org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227

    The path to the plugin is:

    /home/my_name/My_Downloads/xmind2008-linux-i20080331/plugins/org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227

    The name of the plugin is:

    org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227


    I will have to go on my other computer, to look how I solved the problem:

    To be continued.....

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    /home/my_name/My_downloads/Xmind/configuration/config.ini

    The config.ini file...:

    Add this piece of code to the existing code of the file:

    <plugin
    id="org.eclipse.core.runtime.compatibility"
    download-size="0"
    install-size="0"
    version="0.0.0"
    unpack="false"/>

    Ok. Next:

    /home/my_name/My_downloads/Xmind/configuration/

    Get the the jar file from plugin:
    org.eclipse.core.runtime.compatibility.registry_3. 2.100.v20070316.

    Att: /my_name/My_downloads/Xmind/plugins/

    The name of the jar file is:

    runtime_registry_compatibility.jar

    Add runtime_registry_compatibility.jar to the folder content..:

    /home/alexander/My_downloads/Xmind/configuration/runtime_registry_compatibility.jar

    Ok, folder completed and edited. Next:

    Create a folder "icon", and get a Xmind-icon from the internet/pictures, and place it in that folder.

    Next:
    /home/my_name/My_downloads/Xmind/

    In the main Xmind folder you place another configuration/runtime_registry_compatibility.jar file.

    And in the xmind.ini file, you add also the code:

    <plugin
    id="org.eclipse.core.runtime.compatibility"
    download-size="0"
    install-size="0"
    version="0.0.0"
    unpack="false"/>

    Next:

    From the plugins folder you get a copy (but please only a copy) of:
    org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227
    and place it in the main folder:

    /home/my_name/My_downloads/Xmind/org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227

    BTW:
    Here you should also put a copy of the jar file, so your path will look like this:
    /home/my_name/My_downloads/Xmind/org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227/META-INF/runtime_registry_compatibility.jar

    And put a copy of the jar file in the org folder of the same folder:

    /home/my_name/My_downloads/Xmind/org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227/org/runtime_registry_compatibility.jar

    Note, that you have a "eclipse"-folder in the "org"-folder.

    You must install eclipse from the eclipse website: Get the newest version.
    .
    Indide of the plugin you will find: a file plugin_your country.properties.

    Again, add the code, also to this file:

    #Wed Sep 27 04:15:08 EDT 2006
    pluginName=Plug-in-Kompatibilit\u00E4t f\u00FCr Kernlaufzeit
    providerName=Eclipse.org

    <plugin
    id="org.eclipse.core.resources.compatibility"
    download-size="0"
    install-size="0"
    version="0.0.0"
    fragment="true"
    unpack="false"/>

    ---------------------------------------
    Excursion:
    My message is:
    copy and paste the code and jar file in as many places as possible.

    ----------------------------------------------------------------------------------------------------------------

    Next:

    (The relevant plug in the plugin-folder, should also have the jar file runtime_registry_compatibility.jar .)

    (Remember, that the name of our "problem-plugin" is:
    org.eclipse.core.runtime.compatibility.nl1_3.1.100 .v200609270227/)

    Be sure, that the xmind Executable File has the permissions "is executable".

    You should be done, now.

    This is how you start / restart Xmind:

    Use the console, and type (just add "xmind" to the path, because "xmind" is the executable binary file):

    /home/my_name/My_downloads/Xmind/xmind

    "Enter", and the Xmind-flashy should show up, followed by a few windows that prompt you for some decisions and commands. Click yourself through, till you reach the main Xmind application.

    I hope, I haven't missed out anything. It worked for me, on the one computer. Now I will go and see, if I can get it running on the other computer as well. Both computers (PC and laptop) have the operation system "SimplyMEPIS 7.0" installed.

    Be sure, that "pango", "curl", "lame", "glip", and "gtk" are installed to sort out the dependencies.

    And now, enjoy the mind mapping tool: It is one of the very best ones you can find and get.

    It is not free, but you can get a free trial for 30 days.

    Look at tutorial videos in youTube, etc., and for additional information in the Internet.
    I can post some good links here, in a few days.

    Cheers

    P.S.
    I found one of my bookmarked links about mind maps, with loads of interesting a well written comments:
    Assistive Technology: August 2007

    Xmind, is one of them, but probably the best.

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    Yes: It worked.

    I already had eclipse installed, and installed MyEclipse, as well,

    I looked at the execution file, and decided to install tree old versions of glibc.

    Furthermore, I installed linux-source (check the version of your kernel by giving in the command: uname -r ) and installed the linux-headers, as well.

    From the IBM website, I copied and pasted a file, that starts like this:


    1 /************************************************** *****************************
    2 * Copyright (c) 2005 IBM Corporation and others.
    3 * All rights reserved. This program and the accompanying materials
    4 * are made available under the terms of the Eclipse Public License v1.0
    5 * which accompanies this distribution, and is available at
    6 * Eclipse Public License - Version 1.0
    7 *
    8 * Contributors:
    9 * IBM - Initial API and implementation
    10 ************************************************** *****************************/
    11 package org.eclipse.osgi.util;
    12
    13 import java.io.IOException JavaDoc;
    14 import java.io.InputStream JavaDoc;
    15 import java.lang.reflect.Field JavaDoc;
    16 import java.lang.reflect.Modifier JavaDoc;
    17 import java.security.AccessController JavaDoc;
    18 import java.security.PrivilegedAction JavaDoc;
    19 import java.util.*;
    20 import org.eclipse.osgi.framework.debug.Debug;
    21 import org.eclipse.osgi.framework.log.FrameworkLog;
    22 import org.eclipse.osgi.framework.log.FrameworkLogEntry;

    -----------

    I tried many times to start the application, but again, only got the flashy and the old same error message.

    However, just a few minutes ago, the application started like a charm.

    Note: It is a trial version, for 30 days. Close the registration window, without filling it out, and skip it.

    You will get another window, asking you, if you want to skip that part: Click "ok".

    So, now you have the application window. And it looks very similar to the "eclipse"-window.

    Xmind is based on eclipse: If you get a problem with Xmind, and are familiar with eclipse, you are quite fine, because you will be able to manage the problem, most likely.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •