Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Im using PC Linux 2007 I was trying to make a Live USB stick, it said it was completed successfully, but now my system wont boot with or without the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32

    PCLOS HELP...what did I do?


    Im using PC Linux 2007

    I was trying to make a Live USB stick, it said it was completed successfully, but now my system wont boot with or without the USB flash drive.

    with the flash drive in, I get error 16 i think it is, so I assumed I did it wrong, but now when bootint without the flash drive I get the following message and dumped to the shell!

    "Checking filesystems
    fsck.ext3: No such file or dirrectory while trying to open /dev/sda1/dev/sda1:

    The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not a swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

    /dev/hda6: clean, 2137/8241152 files, 520029/16472602 blocks
    [FAILED]
    **** An error occured during filesystem check.
    **** Dropping you to a shell; the system will reboot when you leave the shell"

    sorry for a long post, but I figure it might be helpful, what the heck is going on, its like its still trying to boot from the flash drive even when its not in, how to I fix the problem, and one got any ideas what the problem is?

    havent tried the e2fsck command, not sure how to use it and dont wanna screw anything up...LOL

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    Ok, if I try to boot with the usb stick in, but not from the usb stick, it boots almost all the way and then drops to the command line and prompts for Local host login: and I cant figure out what that is. Hellllppppp! LOL

  3. #3
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,105
    The error messages you refer to in your first post are regarding 'sda1' and 'sda6'. What's on those partitions?

    In your second post, you indicate you get to a login prompt. Did you try to log in? If you can log in as root, enter 'fdisk -l' command and post output here.

  4. #4
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    Yeah, I can get to the root, it dumps me there when I try to boot without the usb stick, the login prompt happens when I try to boot with the stick in but not from the stick, I think I partitioned the usb stick wrong, I was trying to make live USB without reading the forums...Ooops, cause the sda partions refer to the usb stick, my hard drive is hda0 I belive, but it seems like its trying to boot from the stick partition without the stick in and I dont know how to fix it, I will try the command you sugested and post output.

  5. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    Output from fdisk -l
    Device boot start end blocks ID system
    /dev/hda1 * 1 16253 8191480+ 83 Linux
    /dev/hda2 16254 155114 69985944 5 extended
    /dev/hda5 16254 24379 4095472+ 82 Linux swap/Solaris
    /dev/hda6 24380 155114 65890408+ 83 Linux

    I still have my live cd, but I dont know if that will help because I have done alot of updates since then, my kernal is different, but I have seen posts where you can use the live cd to recover the the system, but maybe there is an easier way. Thats why I was trying to make a live usb so I had a backup if something failed, the iso for my current system is too big for a CD and I dont have a dvd burner on this system.

    Any help is appreciated...sorry it took so long to post back, I had to work all day!

  6. #6
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    here is a pic of my hard drive partition, something doesnt look right, I dont think it looked like this before.

    Should there be 2 mounted partitions?

    Im using my live cd to get access to stuff within a functioning linux system!
    Also here is what the fstab file looks like, thought maybe it would be helpful to:

    # /dev/hda1, size=16382961, type=131: Journalised FS: ext3 (primary)
    /dev/hda1 / ext3 defaults 1 1
    none /dev/pts devpts mode=0620 0 0
    # /dev/hda6, size=131780817, type=131: Journalised FS: ext3 (extended)
    /dev/hda6 /home ext3 defaults 1 2
    # fd: H1440
    /dev/fd0 /mnt/floppy auto user,exec,rw,noauto 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs defaults 0 0
    /dev/sda1 /usr ext3 defaults 1 2
    # /dev/hda5, size=8190945, type=130: Linux swap (extended)
    /dev/hda5 swap swap defaults 0 0
    Last edited by rh8807; 08-31-2008 at 04:27 PM. Reason: image to big

  7. #7
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,105
    Your fdisk output shows three Linux partitions, I assume sda1 is your root, and sda5 is swap and sda6 is your /home partition. They show up the same in your fstab but there is no indication of your usb stick in either. Did you have it plugged in/attached when you ran the fdisk command?

    You have PC Linux 2007 on your internal? Is that also what you were trying to install on the USB stick?

    I think you may have installed to your hardrive over what you had there? Maybe? Your fstaab doesn't look right. You have 2 entries for hda1, and 1 for sda1? You also have 2 entries for hda5 (swap) and hda6.

    I assume your root partition is hda1? Check your menu.lst file to see if there is an entry "root (hd0,0). As root, cat /boot/grub/menu.lst.

  8. #8
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    No, I didnt have the stick plugged in when I ran fdisk...the size of the stick was being reported wrong, I have been trying to fix the stick...I might have it now..LOL

    anyway, here is the output from the cat /boot/grub/menu.lst:
    timeout 10
    color black.cyan yellow/cyan
    gfxmenu (hd0,0)/usr/share/gfxboot/themes/pclinuxos/boot/message
    default 0

    title linux
    kernal (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux root=/devhda1 acpi=on resume=/dev/hda5 splash=silent vga=788
    initrd (hd0,0)/boot/initrd.img

    and basically the same settings for linux-nonfb and failsafe, and memtest is a little different if you need the rest of the output I can post it.

  9. #9
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    here is the fdisk -l output on the usb stick...again, I've been messing with the stick, this is what it is currently

    device boot start end blocks ID system
    /dev/sda1 * 1 969 1953472+ 83 Linux

  10. #10
    Just Joined!
    Join Date
    Apr 2008
    Posts
    32
    also on the fstab file, all the lines with a # in front of them are dimmed text, as if they are remarks and not actual entries...if I look at just the bold lines then there is no duplicate entries.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •