Find the answer to your Linux question:
Results 1 to 2 of 2
I've got Oracle Enterprise Linux 5 to install an Oracle server. Checking required packages I found three missing. I located the .rpm files and tried to install manually. The install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    2

    rpm confusion - Oracle Enterprise 5.


    I've got Oracle Enterprise Linux 5 to install an Oracle server. Checking required packages I found three missing. I located the .rpm files and tried to install manually. The install gave a warning, but said the package was already installed. When I tried to find the packages, it said they weren't installed.

    Here is the conversation for one of the packages:

    root@enterprise Server]# rpm -i compat-libstdc++-33-3.2.3-61.i386.rpm
    warning: compat-libstdc++-33-3.2.3-61.i386.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
    package compat-libstdc++-33-3.2.3-61 is already installed

    [root@enterprise Server]# rpm -q -v compat-libstdc++*
    package compat-libstdc++-296-2.96-138.i386.rpm is not installed
    package compat-libstdc++-33-3.2.3-61.i386.rpm is not installed

    I hope I'm just missing something obvious. Any suggestions?

  2. #2
    Just Joined!
    Join Date
    Dec 2008
    Posts
    2

    Found the problem.

    If anyone is interested. I was missing something - but it's less than obvious.

    After lots of google practice, I realized the error message was misleading. Apparently, this and a number of similar packages always give this warning. The problem was the name of the package is unusual. For just about every other package, only the part before the first dash is the package name - the rest is version info. So if I type

    [root@enterprise Server]# rpm -q binutils

    I get the expected response

    binutils-2.17.50.0.6-6.el5.

    However, if I type

    [root@enterprise Server]# rpm -q compat-libstdc++

    as mentioned I get the unexpected

    package compat-libstdc++ is not installed

    The problem is that the '-33' is actually part of the name. So if i type

    [root@enterprise Server]# rpm -q compat-libstdc++-33

    Everything is right with the world:

    compat-libstdc++-33-3.2.3-61

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •