Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 32
Nevermind. I went to the handbook for 2.4, and I found the file I needed. I feel dumb. I had looked at the handbook, but found nothing on Networking. And ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined! aluminumspleen's Avatar
    Join Date
    Oct 2008
    Location
    Dorm Room, America
    Posts
    59

    Nevermind. I went to the handbook for 2.4, and I found the file I needed. I feel dumb. I had looked at the handbook, but found nothing on Networking. And yet, there it is. Thanks.

  2. #22
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Did you use what was here? It's as if it's using a "stock" net file that hasn't been configured as it's asking to fix "127.0.0.1/32" which should of course be 127.0.0.1. I'll try it on my box and see what happens...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #23
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by aluminumspleen View Post
    Nevermind. I went to the handbook for 2.4, and I found the file I needed. I feel dumb. I had looked at the handbook, but found nothing on Networking. And yet, there it is. Thanks.
    Oops... I think remember now you said you were using 2.4. I pulled the above from 2.5. Shouldn't be much of a differnce though.

    EDIT: Just tried the dhcpcd script and got connected. Here's what I got:
    Code:
    bash-3.2# /etc/rc.d/net restart
    Warning: Executing wildcard deletion to stay compatible with old scripts.
             Explicitly specify the prefix length (127.0.0.1/32) to avoid this warning.
             This special behaviour is likely to disappear in further releases,
             fix your scripts!
    eth0: dhcpcd 4.0.7 starting
    eth0: broadcasting for a lease
    eth0: offered 192.168.1.2 from 192.168.1.1
    eth0: checking 192.168.1.2 is available on attached networks
    eth0: acknowledged 192.168.1.2 from 192.168.1.1
    eth0: leased 192.168.1.2 for 86400 seconds
    bash-3.2#
    So I guess that "Warning" is standard. So Debian is on this box too? Are you using dhcpcd or dhclient with it when connecting?
    Last edited by Dapper Dan; 01-04-2009 at 10:26 PM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #24
    Just Joined! aluminumspleen's Avatar
    Join Date
    Oct 2008
    Location
    Dorm Room, America
    Posts
    59
    Yeah, I did a Debian minimal install, and it just auto-configured it when it installed, so I don't know what it's using. I've never been this hands-on with anything on computers yet! Pretty exciting.

    Yeah, it turns out there was a "/8" at the end of the IP address in the 2.4 handbook, and I added it on my file, and boom, it worked.

    Got a bunch of ports on there, and am starting to build a system. Screenshots to come!

  5. #25
    Just Joined! aluminumspleen's Avatar
    Join Date
    Oct 2008
    Location
    Dorm Room, America
    Posts
    59
    Xserver isn't being very friendly. Whenever I 'startx', it brings me up to three terminals on a weird gray background. When I exit all the terminals, it brings me back to the command prompt, with a bunch of info/error messages.

    Code:
    (EE) Unable to locate/open config file
    New driver is "nv"
    (==) Using default built-in configuration (55 lines)
    (EE) open /dev/fb0: No such file or directory
    (II) Module "i2c" already built-in
    (II) Module "ddc" already built-in
    (II) Module "ramdac" already built-in
    /usr/lib/X11/xinit/xinitrc: line 28: twm: command not found
    /usr/lib/X11/xinit/xinitrc: line 29: xclock: command not found
    
    waiting for X server to shut down xterm: fatal IO error 11 (Resource temporarily
    unavailable) or KillClient on X server ":0.0"
    xterm: fatal IO error 11 (Resource temporarily unavailale) or KillClient on 
    X server ":0.0"
    FreeFontPath: FPE "/usr/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.
    Gonna go try to install xclock and twm, we'll see. Any other ideas? It says xorg is installed (and it clearly is), so I don't know what to do.

  6. #26
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by aluminumspleen View Post
    Xserver isn't being very friendly. Whenever I 'startx', it brings me up to three terminals on a weird gray background.
    That would be TWM. Which WM are you going with? While TWM is up, I think it will revert to openbox (WM in CRUX 2.5 by install) if you run the openbox command. Or, edit /usr/lib/X11/xinit/xinitrc to run the WM of your choice. See the thread Jay started for more on that. But at least you're getting X!
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #27
    Just Joined! aluminumspleen's Avatar
    Join Date
    Oct 2008
    Location
    Dorm Room, America
    Posts
    59
    Hey yeah, at least I'm getting X! I'm gonna take a page out of your and Jay's book, and give IceWM a whirl. I just edited the xinitrc, and got IceWM to pop up! But when Ice comes up, I still get a terminal, and when I close it, X exits. How do I get rid of that? I'm so close!

  8. #28
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    See my post about 2/3rd of the way down this page on how to get it fixed.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #29
    Just Joined! aluminumspleen's Avatar
    Join Date
    Oct 2008
    Location
    Dorm Room, America
    Posts
    59
    Well, I've got me a working computer. I don't know about sound or video or whatnot, but I've got a sparkly IceWM CRUX. Now, to figure out how to set the desktop background and take a screenshot...

  10. #30
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    You'll likely have to copy over a "ghost" image of your icewm configuration directory to your /home directory. As root:
    Code:
    cp -r /usr/share/icewm /home/aluminumspleen
    *replace aluminumspleen with whatever the name of your home directory is...*

    Then:

    Code:
    cd /home/aluminumspleen
    Code:
    mv icewm .icewm
    Code:
    chown -R aluminumspleen:users .icewm
    Now that you have a template:
    Code:
    vi .icewm/preferences
    Scroll all the way to the bottom. Look for this third entry up from bottom:
    Code:
    #  Desktop background image
       DesktopBackgroundImage=""
    Make sure it's uncommented and put the path of your desired background between the quotes. For instance, say I downloaded "background.jpg" in my home directory. It would look like this:
    Code:
    #  Desktop background image
       DesktopBackgroundImage="/home/dapper/background.jpg"
    Another thing that will save time... Whatever screen resolution you are running, resize the image to that. I use 1024x768 so I'd scale my desktop image to those dimensions. Or, in ~/.icewm/preferences, the fifth up from bottom gives you the choice of full screen or scaled:
    Code:
    #  Desktop background scaled to full screen
       DesktopBackgroundScaled=0 # 0/1
    Change the "0" to a "1" if the image is larger or smaller than your resolution.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •