When I install the latet edition of Sun-Java6 with synaptic,
then I go test it using my browser konquerer at:

How do I test whether Java is working on my computer? - 1.4.2_xx, 1.5.0, 6.0

the test failed, and no little dancing Java stickman!

During the test I see a small icon appear on lower right
corner of browser and I clicked on it and get this error message
in a popup page/window.

The popup error page/window:
~~~~
TestVM 8.18 sc
Copyright (c) 2008 Sun Microsystems, Inc.
All Rights Reserved.
Current JRE version set in file:
Error during state 3
Backtrace:
java.lang.NumberFormatException: For input string: " "
at
java.lang.NumberFormatException.forInputString(Num berFormatException.java:4
at java.lang.Integer.parseInt(Integer.java:447)
at java.lang.Integer.<init>(Integer.java:620)
at
testvmDynamicJavaComPopUp819.init(testvmDynamicJav aComPopUp819.java:269)
at
org.kde.kjas.server.KJASAppletStub$RunThread.doSta te(KJASAppletStub.java:196)
at
org.kde.kjas.server.KJASAppletStub$RunThread.run(K JASAppletStub.java:255)
Exception in thread "Thread-5" java.lang.NullPointerException
at testvmDynamicJavaComPopUp819.run(testvmDynamicJava ComPopUp819.java:440)
at java.lang.Thread.run(Thread.java:619)
~~~~

Please, can someone tell me what it's trying to
tell me? and maybe I can figure out what went
wrong to fail the Java test.

According to "All" the post and "All" the websites
I have been to trying to learn how to install Java
it should be working okay.

As root, after installing sun-Java6 with synaptic
I ran this from the command line:

update-alternatives --config Java

and then did a version check, it was okay.

then I did a version check as user it was okay also.

Next I followed the instructions on the Sun site:

- Enable Java through your Web browser
"My browser(konquorer) was not listed".

- Enable Java through the "Java Plug-in Control Panel"
I checked it and it was already enabled.

- Clearing your Web Browser Cache
I cleaned the cache, and tried again.

BTW, when I get to Suns site and the page starts to load
it says down on the left lower status bar:

applet "" started

and it shows in the window where the applet should be
running:

Loading Applet

I have uninstalled and re-install, and re-did all the above
so many times over a four day period. Stopped for Christmas
and now I'm at the end of day 5.

HELP PLEASE!

Thanks in advance for being able to post and all your help!