Find the answer to your Linux question:
Results 1 to 5 of 5
Hello I have tried everything, but i am just stuck I get this error when i try to compile a new kernel Image - TinyPic - Free Image Hosting, Photo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3

    Can't figure out why init wont load


    Hello

    I have tried everything, but i am just stuck

    I get this error when i try to compile a new kernel
    Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting

    pastebin - collaborative debugging tool --> .config

    pastebin - collaborative debugging tool --> lspci -v

    pastebin - collaborative debugging tool --> /boot/grub/menu.lst
    line 25 is what im trying to load and line 21 is what is working at the moment


    i dont understand where the problem is, someone please help me, i am really stuck

    I compiled this system by reading LFS, this isnt a distro, ive even tried reinstalling sysvinit-2.86

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    Have you tried adding the init= parameter to the kernel line in grub's menu.lst? init should be at /sbin/init so the line should look something like:
    Code:
    kernel /lfskernel-2.6.22.2 root=/dev/hda2 init=/sbin/init
    You might just have to check that that's where it is though.

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    ive tried that, and please read the whole thread next time, not being rude, but i can see you didnt

    i appreciate your effort though

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    What's your partition layout? just wondering as the root line doesn't match the root param in the kernel line, I take you have /boot on it's own partition?

    Try sticking a hello world shell script in / and point the kernel's init param at it, it should print out hello world before dieing then. Just wanna check the kernel can access the init script.

    Also you seem to have initrd enabled in the kernel, but aren't using it to boot, try disabling it and see if that makes any difference.

  6. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    ImageShack - Image Hosting :: dsc01150sf6.jpg i tried that


    I purposly entered the wrong information and this spat out
    ImageShack - Image Hosting :: dsc01151uo3.jpg
    tells me what my kernel sees

    What I dont get, is if it sees it all, and can read ext3, why isnt it just loading

    i will try disabling initrd and post results tomorrow, i need some shuteye

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •