Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
I'm new to linux, and installed Linux Mint a few days ago. While it is a very nice operating system, i wanted to try something else. So i downloaded and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15

    How do i stop grub and allow live CD's to boot?


    I'm new to linux, and installed Linux Mint a few days ago. While it is a very nice operating system, i wanted to try something else. So i downloaded and burnt a live CD of openSUSE 11.1. I tried to boot from it, but my computer always starts loading mint as though there were no cd in the drive. I changed the BIOS to boot from the cd, but that didnt work either. I held F12 and chose to boot from cd. That didnt work either. It just kept going to mint. so using parted magic, i deleted the partition hoping that with mint gone i would be able to boot from a cd. (as of now i have no operating system installed) Instead, i start the computer and hold F12, choose boot from cd, but it goes directly to grub. grub starts loading, but then says error 22. I've tried numerous live cd's, super grub disk, etc. but it always goes to grub then says error 22. So my question is, how do i stop grub from starting, and let the live CD boot?

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    Maybe a bad burn to CD/DVD. You can check the following HowTo for instructions on properly downloading the ISO file and then burning it to disk as an image:

    http://www.linuxforums.org/forum/ins...ll-cd-dvd.html

    The howto also covers properly booting from such disks.
    oz

  3. #3
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    I think your problem is likely to be either:-
    1. live CD incorrect burning
    2. downloaded iso file corrupted
    3. anti-virus set on in BIOS preventing CD boot & possible write to MBR

    Check in order ...
    BIOS virus protection is set off
    iso file md5sum to confirm it is not corrupt (check against download website value)
    ensure you burn CD correctly at minimum speed.

    Does the system still boot from the PartedMagic CD?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15
    Well, i never had a cd for partedmagic, it was just an option at the linux mint boot screen. also, i have tried using live cd's that have worked in the past so i know they are not corrupt, and they don't work. Is there any way to simply get rid of grub, or will that not help?

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by rynlacr View Post
    Is there any way to simply get rid of grub, or will that not help?
    No, it won't help if the disk is not burned correctly, or the image was corrupted. If you are sure that you want to remove GRUB, then you can clear the MBR (master boot record) only, and leaving partition tables alone, by going to a terminal and running the following dd command:

    Code:
    dd if=/dev/zero of=/dev/sda bs=446 count=1
    You'll need to replace /dev/sda with your actual device name such as /dev/hda.

    If needed, you can use the fdisk -l command to determine your device name:

    Code:
    fdisk -l
    If you use sudo rather than su to gain root permissions, be sure to put it in front of the dd command as with any other command that needs it.
    oz

  7. #6
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Suggest you try to sort out the BIOS setup, check other things first ...

    You can remove grub from the MBR but I recommend you don't do this as this will stop the system from booting at all

  8. #7
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15
    How do i get into terminal?

  9. #8
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    If you have a working Mint system and you run Gnome, you should find Terminal in the applications menu, or perhaps an icon for starting it in your panel. If you run KDE, the application will be called Konsole, and can be found the same way. Be sure that you really want to remove GRUB before doing so.
    oz

  10. #9
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15
    i dont have a working mint system. in fact, i have no operating system at all. all that happens upon starting the computer is grub starts up, then says this

    GRUB Loading stage 1.5.


    GRUB loading, please wait...
    Error 22

    i have burned numerous copies of these cd's at the slowest speed possible, and im getting them directly from the distribution website so i doubt they are corrupted.

  11. #10
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    If you are sure that you are burning the ISO files as images to the disks and that the disks should be good, try testing them on another machine. If they work there, but not on this certain machine, perhaps the drive is bad or it doesn't like the media that you are using.

    You could also test your cd/dvd drive by booting the Windows installation CD or some other "known to be good and bootable" media to see if it will work.
    oz

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •