Find the answer to your Linux question:
Results 1 to 2 of 2
Howdy everybody. I'm going nuts trying to get the sound to work in DSL. My dad gave me his ancient laptop for christmas - it came packaged with windows 95 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1

    Sound/ALSA in DSL with OPL3-SA2


    Howdy everybody.

    I'm going nuts trying to get the sound to work in DSL.

    My dad gave me his ancient laptop for christmas - it came packaged with windows 95 (although he had updated it to 9. Not wanting to wade through that outdated pile of crap of an operating system, I decided to format and install linux.

    I tried a variety of distros, upwards of 10, and DSL was the only one that even managed to boot correctly. Actually, feather linux worked too but it seems much slower than DSL and just altogether not as well put together. Besides, sound didn't work in feather either.

    DSL actually works great for the most part on this laptop. The only problem is the sound - there is none. If I try to play a sound in XMMS I get a window saying

    Couldn't open audio.
    Please check that:
    1. You have the correct output plugin selected
    2. No other programs is blocking the soundcard
    3. Your soundcard is configured properly

    I'm just using XMMS as an example - nowhere in my DSL install does the sound work. When I open the mixer it comes up showing the volume as being all the way down. When I try to click and drag it to turn it up the program just closes instantly.

    I swear I've tried everything. I tried installing the 4 or 5 different myDSL ALSA packages and following the instructions for each. All of these would seem to install fine, but the sound still didn't work afterwards.

    I tried to apt-get the alsa drivers but ultimately run into errors about dpkg returning error code (1) - this seems to be a problem with dpkg and not anything to do with the sound on my computer, but it is preventing me from getting alsa to work through apt-get nonetheless. I have gotten other packages to install through apt-get, however, so I don't know why this one is acting up.

    I tried going about it the old-fashioned way and just downloading the driver, libs, and conf source files, but when I try to ./configure I get an error:

    "The file /lib/modules/2.4.31/build/include/linux/version.h does not exist. Please install the package with full kernel sources for your distribution."

    I continue to get this error even after installing the kernel headers from the myDSL package manager!

    So basically I've tried pretty much everything I could possibly do on my own to get this to work, and have failed, so now I'm looking for help.

    Oh, I also tried running alsaconfig once after having installed every myDSL alsa package. I don't remember exactly how that panned out, but I know that alsaconfig initially detected an OPL3-SA2 sound card but that the default dma & irq channels were not correct (or something like that? I don't know squat about IRQs and such), so it needed to detect the correct ones. Then it told me it couldn't find my sound card and gave up! Attempts to run alsaconfig since then have failed with DSL telling me there is no such command. I'm curious as to how that application just disappeared after I ran it once? By the way, I have totally reinstalled dsl, installed various ALSAs from the myDSL package manager again, and tried to run alsaconfig but got the same warning that there was no such command/application. One of the most perplexing and aggravating things I've run into since I set off on my adventure into the land of linux.

    If its useful, here is my computer:
    Toshiba Satellite 315cds
    200 mhz pentium processor
    64 mb ram
    OPL3-SA2 sound card - I have no official documentation or proof that this is actually my sound card, but all evidence seems to point toward it - when I google "toshiba satellite 315cds sound card" I get all kinds of references to the OPL3-SA2. And the one time i managed to get alsaconfig to run the first suggested sound card on the listi t gave me was "OPL3-SA2."

    Does anyone know how to fix this? Perhaps somebody has managed to get an OPL3-SA2 sound card to work with DSL and can help me out? Please?

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,966
    Does anyone know how to fix this? Perhaps somebody has managed to get an OPL3-SA2 sound card to work with DSL and can help me out? Please?
    I haven't. Did you try the latest instructions from this page?

    Matrix:Module-opl3-sa2 - AlsaProject

    Also, this next link shows Kernel configuration for a 2.4 kernel (which I am pretty sure DSL uses) on a Toshiba 445 CDT with your sound card that might be helpful. This is about all I can help you with. Good Luck

    TuxMobil: Sound Card Support for Linux with Laptops and Notebooks
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •