Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
I downloaded jre, it comes in a bin file, everytime I sh it after it shows me the liscence agreement it says there is an error in extracting the file ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    California (Bay Area)
    Posts
    23

    Java not quite there


    I downloaded jre, it comes in a bin file, everytime I sh it after it shows me the liscence agreement it says there is an error in extracting the file and do not use it because it is corrupt, Any ideas? Thanks for reading. :P

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Redownload the file?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    99% chance, its actualy currupt, try getting it again.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    59
    where/how did you download it from?

  5. #5
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    the java sun site provides runtime envs, and JDK's along with the free IDE NetBeans
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  6. #6
    Just Joined!
    Join Date
    Sep 2004
    Posts
    59
    correct - just curious because I am having the same trouble with the java download from http://www.java.com/en/download/manual.jsp

    tail: `-1' option is obsolete; use `-n 1'
    Try `tail --help' for more information.
    ./j2re-1_4_2_05-linux-i586.bin: line 327: [: -lt: unary operator expected
    Unpacking...
    tail: cannot open `+479' for reading: No such file or directory
    Checksumming...
    1
    The download file appears to be corrupted. Please refer
    to the Troubleshooting section of the Installation
    Instructions on the download page for more information.
    Please do not attempt to install this archive file.

  7. #7
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    if you use and ASCII download is it possible that could corrupt it? Reguardless, here is a mirror with a checksumed file, but the speeds on it are gonna be slow, its the jdk i installed on my machine, worked fine, then i overwrote it recently from portage, but here let me know.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  8. #8
    Just Joined!
    Join Date
    Sep 2004
    Location
    California (Bay Area)
    Posts
    23
    hmm, the link u gave does work but the jre still isn't installed and thats what you need to use java online. Im just gonna keep experimenting. Mine's the same error as bionnaki's. Maybe this is an error on sun's side..

  9. #9
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    did the install of it work? you just need symlink it into the plugin dir for firefox
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  10. #10
    Just Joined!
    Join Date
    Sep 2004
    Location
    California (Bay Area)
    Posts
    23
    ya, the installation of jdk worked... I confess I have no clu how to sym link stuff... but I followed the guide to installation on the java site and got a dependencie error and the dependencies arnt in portage...

    Do you agree to the above license terms? [yes or no]
    yes
    Unpacking...
    Checksumming...
    0
    0
    Extracting...
    UnZipSFX 5.42 of 14 January 2001, by Info-ZIP (Zip-Bugs@lists.wku.edu).
    inflating: jre-1_5_0-rc-linux-i586.rpm
    error: Failed dependencies:
    sh-utils >= 2.0-1 is needed by jre-1.5.0-rc
    textutils >= 2.0-2 is needed by jre-1.5.0-rc

    Done.

    hmm... Anyone know where/how to get those?


    woot, problems stacking up, just apt-get insall firefox, and I cant run it, I type in firefox in console and it thinks for a while and does nothing, hopefully restarting will solve this.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •