Find the answer to your Linux question:
Results 1 to 6 of 6
I have partitioned and formatted a 500gb external drive under ydl and created a mount point /ydl1. upon booting I get the following message. fsck.ext3: unable to resolve "LABEL=ydl1' *** ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2009
    Posts
    3

    Exclamation fsck.ext3:unable to resolve 'LABEL=ydl1'


    I have partitioned and formatted a 500gb external drive under ydl and created a mount point /ydl1. upon booting I get the following message.


    fsck.ext3: unable to resolve "LABEL=ydl1'

    *** an error occurred during the file system check.
    *** dropping to a shell; the system will reboot
    *** when you leave the shell.

    give root password for maintenance
    ( or type control-d to continue)

    when I enter root password it replies

    (repair filesystem) 1 #

    I have no idea what to reply
    I can't bypass and thus the system is unbootable.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Try using actual device name ( /dev/sdxy) instead of /ydl1. You have to edit /etc/fstab and /boot/grub/menu.lst files for that.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Feb 2009
    Posts
    3
    Thanks for the reply.

    The problem is that I don't know how to use the emergency repair function and thus can't get on the system to do anything to the fstab to correct the problem.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Do you have LiveCD of any Linux distro? You can you installation disk to boot up in Rescue mode. Mount partition using mount command and edit files.
    Boot up from Installation disk. Does it show Rescue/Recovery mode in menu?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Feb 2009
    Posts
    3
    I have an ISO dvd that I installed from. The system doesn't get to the point of reading the dvd before it goes in the emergency shell prompt.
    I'm able to vi the /etc/fstab
    I know exactly what i have to change however when in insert mode or replace mode in vi I get this message

    w10: changing a readonly file

    when I enter the change required the system responds

    E303: unable to open swap file for "/etc/fstab", recovery impossible
    press enter or type command to continue

    I press enter

    then ZZ

    system responds

    E45: "readonly" option set (add ! to override)

    I've tried chown command on both dir and file it says it is changing the readonly dir or file but nothing occurs.

    As root I should be able to do whatever I want but can"t.

  7. #6
    Just Joined!
    Join Date
    Jul 2009
    Posts
    1

    You need to remount / in rw mode

    I ran into the same problem, I was trying to mount an iSCSI volume at boot and added the wrong fsck switches in /etc/fstab. So @ # (repair filesystem) type mount / -o rw,remount
    then edit away.
    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •