Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
I recently intalled KateOS 3.6 on an old PC setup, including it's old monitor. I now want to use use it with my LCD monitor, but some of the text ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40

    Question [SOLVED] Auto-Detect New Monitor in KateOS?


    I recently intalled KateOS 3.6 on an old PC setup, including it's old monitor. I now want to use use it with my LCD monitor, but some of the text is off the screen, so I need reconfigure the display settings. Can anyone advise how I go about this please? Does Linux (and KateOS in particular) support auto-detect, or do I need to tweak something manually?

    Any help much appreciated ... I'm brand new to Linux.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I'm not familiar with KateOS, but you probably need to reconfigure your xorg.conf file. (Located at /etc/X11/xorg.conf).

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40
    Thanks.

    Took me a while just to find the file ... and then to look inside it! ("locate", then "less"). Still getting to grips with the very basic basics! "ls etc" didn't seem to show X11 directory. Eventually sussed it's shown first 'cos it's uppercase X, and because my monitor settings are off only half the X was showing ... looked like C11 ... !?

    Looked in xorg.conf and just one monitor section is shown which very clearly relates to the old CTX monitor, but nothing for the new LG one. Says these are the DDC-probed settings for that monitor ... surely there must be a way therefore to DDC-probe the new monitor? Trouble is I can't suss how?

    I know when I installed KateOS it ran some sort of config utility with what looked like a simple graphical front end to it. Can't help wondering if that's what I need to run up again, but I don't have a clue how to get back to it again. I don't want to rerun the whole install again in case it messes something up.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40
    Just realised something maybe? I'm not running the GUI, I'm just running the command interface. Does this mean xorg.conf is a red herring for my problem, and that something else is the problem?

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Hmm, yeah, xorg.conf is the configuration file for the X Windows System; if you're not running X, I don't think that would be the place to fix the monitor problem. I'm really not sure then. My somewhat limited knowledge would suggest that you need to adjust the framebuffer. Key words I would google for are tty, framebuffer, console, resolution. Hopefully that can point you in the right direction.

    I looked into KateOS a little, and I see it's based on Slackware, so solutions pertaining to Slackware should be applicable.

    Out of curiosity, why are you running this distro? Looks like it hasn't had a release since 2007... You might be happier running pure slackware, or, depending on just how old your machine is, Arch Linux. (Gotta have an i686 processor for Arch.)

  7. #6
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40
    I want to learn Linux for two reasons:
    • Lots of embedded software engineer jobs are Linux these days, need to learn it.
    • Fancy learning it anyway.

    Slackware seemed a good bet as it's pretty pure Linux from what I've read. But I've raked out an old PC for learning Linux on, and Slackware is much too resource hungry for it - 600M Athlon, 10G disc, 256K RAM. KateOS looked the ticket - lightweight distro that seems to be well regarded. KateOS web site says v4.0 held up because they lost one of their key programmers.

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Add vga=773 at the end of kernel line in /boot/grub/grub.conf ( or menu.lst file ).

    Code:
    su -
    nano /boot/grub/grub.conf
    Press Ctrl+X, Y and hit Enter key to save file. In case, nano is not available, use vi.
    Last edited by devils casper; 04-11-2009 at 03:50 AM.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Add vga=773 at the end of kernel line in /boot/grub/grub.conf
    I'd wager being based on slackware that KateOS uses lilo. Assuming that is the case, you'd need to edit /etc/lilo.conf It would look something like this

    Code:
    boot = /dev/hda
    delay = 40
    compact
    vga = 773
    root = /dev/hda1
    read-only
    image = /zImage-2.5.99
            label = try
    image = /zImage-1.0.9
            label = 1.0.9
    image = /tamu/vmlinuz
            label = tamu
            root = /dev/hdb2
            vga = ask
    other = /dev/hda3
            label = dos
            table = /dev/hda

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Don't forget to execute lilo command after editing lilo.conf file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined!
    Join Date
    Apr 2009
    Location
    South East England
    Posts
    40
    Thanks everyone.

    I think I may have been leading us all a bit of a merry dance? My set up is this ...
    • Two PCs, one running Windows and the other KateOS Linux.
    • KVM switch so I can use the same monitor, keyboard and mouse, and just switch between the two PCs.

    I've wanted to avoid keep changing the monitor's own adjustments, as that would be a real pain to keep twiddling them.

    Can see no sign of lilo.conf in /etc, doesn't show up anywhere in fact when I run 'locate'. Apparently this latest (and maybe some earlier) version of KateOS is not explicitly based on Slackware, though still borrows much from its philosophy as I understand it.

    My monitor problem is not a Linux one I eventually realised. When starting up the Linux PC the BIOS messages show the same slight off-screen problem, so we are talking a basic graphics card / monitor issue ... which is what the monitor adjusters are for. As I switch PCs of course the monitor is being driven by different graphics cards.

    The optimal resolution for my monitor is 1280x1024, so I initially tried setting vga=795 which gives 24-bit colour depth, but KateOS doesn't recognise it and the display goes almost unreadable. So I tried 794 which is 16-bit and that works just fine.

    I've now realised my monitor (LG L1953S) has an auto-position feature, so each time I switch PC I just have to press this and it sorts itself out very nicely. Two buttons to press instead of one, but I can live with that.

    I think I'll move onto checking out display of the X Windows side of things while I'm about it, so that info you folks have advised me on will be useful also.

    Oh yes, what is LILO's job in life?

    So in the process of all this I've learnt quite a lot - thanks to you all.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •