Can anyone help me get this working? So far I've tried Alsaconf and when that didn't work, the following changes - based on hours of scouring the web...:
In BIOS disable serial and parallel ports.
Add to menu.lst
acpi=off pnpbios=off
Comment out of modprobe.conf:
#options sb io=0x220 irq=7 dma=1 dma16=5 mpu_io=0x330
# alias snd-card-0 snd-cs4232
# alias sound-slot-0 snd-cs4232
then in an rxvt window:
modprobe snd
modprobe snd-cs4236 port=0x530 cport=0x210 irq=5 dma1=0 dma2=1 mpu_port=0x330 isapnp=0 fm_port=0x388 mpu_irq=13
As alsaconf -R had indicated that irq's 5 and 13 and DMA's 0 and 1 were free.
On entering the command there's a low click from the speakers, Dmesg lists no errors and Alsaconf -R then shows DMA 0 and 1 allocated to CS4231, IRQ5 to CS4231 and IRQ13 to MPU401 UART which looks good.
I then used Alsamixer to switch on Master D and PCM, gave each some volume and tried Pmusic to play some .wav files from /usr/share/sounds
Not a peep! :o(
Does anyone at least know whether it's possible to get this working? I've heard of a relevant kernel patch but the posting was archived so I assume that was old news.
Brian