Find the answer to your Linux question:
Results 1 to 2 of 2
I have a friend who has Xandros on a desktop machine who is too far away from the router, so needs to connect wirelessly. I'm familiar with a few linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    1

    wireless - not connecting


    I have a friend who has Xandros on a desktop machine who is too far away from the router, so needs to connect wirelessly. I'm familiar with a few linux distros, but not Xandros, but I figured I could help since I'm pretty good with Kubuntu.

    Well, nevertheless, I'm not as good as I thought I was. Here's the setup:

    Xandros Pro 4 using kernel 2.6.18-dcc.uni using wpa_supplicant 0.5.5

    I installed a WG311 from linksys since it seemed like people in various linux forums were able to get it working.

    And, indeed, after doing the ndiswrapper thing (ie, installing the windows driver), I can do a
    $iwlist eth0 scanning
    and it will show the two wireless access points and various information about them.

    Unfortunately, that's it; it will NOT connect to the WPA SSID (which uses a passphrase). It seems attached to eth0 (instead of wlan or ath0) and the "built in" network management tool (which is pretty good by the way), seems to allow making a WPA connection.

    Some interesting things to note is the the SSID has a space in it and when I looked at the xandros-created /etc/wpa_supplicant.conf.eth0, it only put the first word in the "network = {" part. I tried fixing it and rerunning wpa_supplicant -Bw -c/<file> -dd , but it still couldn't get an ip address.
    I also tried "forcing" an ip address with ifconfig eth0 <address>, still nothing -- of course I didn't set a gateway or DNS server because I couldn't remember how to do that.

    I tried hand connecting a number of ways including using dhclient on eth0, but it doesn't get an IP address.

    Any suggestions?
    Kurt

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I'd have to say, start here and post the required info back into this thread.
    http://www.linuxforums.org/forum/wir...tart-here.html
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •