Find the answer to your Linux question:
Results 1 to 2 of 2
scim_hangul_imengine.cpp:692: error: 'strlen' was not declared in this scope make[2]: *** [hangul_la-scim_hangul_imengine.lo] Error 1 make[2]: Leaving directory `/root/Desktop/scim-hangul-0.3.1/src' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/root/Desktop/scim-hangul-0.3.1' make: *** [all] ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    1

    Unhappy scim-hangul error


    scim_hangul_imengine.cpp:692: error: 'strlen' was not declared in this scope
    make[2]: *** [hangul_la-scim_hangul_imengine.lo] Error 1
    make[2]: Leaving directory `/root/Desktop/scim-hangul-0.3.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/Desktop/scim-hangul-0.3.1'
    make: *** [all] Error 2

    What's that mean? and how can I fix it?
    Thanks in advance for your help...

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    1
    I dealt with this error by editing two files; /src/scim_hangul_imengine.cpp and /src/scim_hangul_imengine_setup.cpp.

    In both instances I added #include <string.h> to the top and the make resolved fine and I can now see Korean as an option in Xwindows.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •