Find the answer to your Linux question:
Results 1 to 9 of 9
Greetings, I'm new to Linux but not to computers. I recently installed MEPIS 8.0 after enjoying my experience with it as a Live CD. After about a week of using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Location
    New Mexico
    Posts
    5

    GRUB won't load after installation


    Greetings,

    I'm new to Linux but not to computers. I recently installed MEPIS 8.0 after enjoying my experience with it as a Live CD. After about a week of using it, I decided to remove WinXP since I didn't want to upgrade to Win7, and I installed MEPIS Linux as my only OS. Now that MEPIS is installed, I can't boot with it from the hard drive. GRUB never comes up at all and I get a flashing underscore with a dark screen. I have no other OS installed either and I only use one SATA hard drive. GRUB was installed to the MBR.

    I tried rebooting with the LiveCD and I used the System MEPIS Assistant ->Repair System Boot and reinstalled GRUB to the MBR. I made sure "Use initrd" was checked. This didn't work. I then tried installing it to the root partition using this same menu--this didn't work either. Below is /sda1/boot/grub/menu.lst

    Code:
    timeout 15
    color cyan/blue white/blue
    foreground ffffff
    background 0639a1
    
    gfxmenu /boot/grub/message
    
    title MEPIS at sda1, newest kernel
    root (hd0,0)
    kernel /boot/vmlinuz root=/dev/sda1 nomce quiet splash vga=791 
    initrd /boot/initrd.img
    boot
    
    title MEPIS at sda1, previous kernel (if any)
    root (hd0,0)
    kernel /boot/vmlinuz.old root=/dev/sda1 nomce quiet splash vga=791 
    boot
    
    title MEPIS at sda1, kernel 2.6.27-1-mepis-smp
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.27-1-mepis-smp root=/dev/sda1 nomce quiet splash vga=791 
    initrd /boot/initrd.img-2.6.27-1-mepis-smp
    boot
    
    title MEMTEST
    kernel /boot/memtest86+.bin
    BTW, I even tried installing other distros like Ubuntu and Debian and they have the same problem among others, so I reinstalled MEPIS again. I hope I can get this fixed before school starts in January otherwise I will have to go back to Windows again to do my school work. Any help is greatly appreciated. Thanks.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Post the output of sudo fdisk -l command here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Location
    New Mexico
    Posts
    5
    Thanks for the quick response. Here's the output of the command:
    Code:
    mepis1:/home/demo# sudo fdisk -l
    
    Disk /dev/sda: 320.0 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000cadee
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1       38531   309500226   83  Linux
    /dev/sda2           38532       38913     3068415   82  Linux swap / Solaris
    
    Disk /dev/sdb: 4063 MB, 4063232000 bytes
    5 heads, 32 sectors/track, 49600 cylinders
    Units = cylinders of 160 * 512 = 81920 bytes
    Disk identifier: 0x00000000
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *          51       49600     3963968    c  W95 FAT32 (LBA)
    I think /dev/sdb1 is my USB flash drive, if not I'm not mistaken.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Remove quiet splash vga=791 options from kernel line in menu.lst file and check it display anything on reboot.

    Does anything appear at startup? Are you sure that you Harddisk has been set as First Boot Device in BIOS and its not disabled?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Dec 2009
    Location
    New Mexico
    Posts
    5
    Oh, I see what your saying. The hard disk is listed as second after the CD-ROM in the BIOS. I know this isn't an issue because I was running WinXP two days ago off the hard disk and I have not changed anything in the BIOS. I will remove the lines from menu.lst to see what happens.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Problem is, GRUB Menu is not appearing at all. It means BIOS is not reading MBR of its harddisk at all or GRUB has not been installed there.

    In case GRUB Menu doesn't appear after removing options from kernel line, re-install GRUB Manually.
    There are a lot of ways to do that.

    Boot up from Mepis LiveCD, open Terminal and execute this
    Code:
    sudo grub
    You will get a grub prompt, grub>
    Execute this:
    Code:
    find /boot/grub/stage1
    If you get "Error 15: File not found", try the following:
    Code:
    find /grub/stage1
    Using this information, set the root device (fill in X,Y with whatever the find command returned):
    Code:
    root (hdX,Y)
    setup (hd0)
    quit
    Reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Dec 2009
    Location
    New Mexico
    Posts
    5
    I double checked the BIOS and the hard drive is listed right after the CD-ROM in the boot priority. I cannot make the hard drive have priority over CD-ROM unless I disable booting from the CD altogether.

    After removing the /boot entry from the kernel and initrd lines, I still don't get anything but a blinking underscore at the top left hand corner of the screen. I then removed the splash entry and still GRUB does not show up.

    I tried reinstalling GRUB manually like you said. I did this:
    Code:
    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)
    
     [ Minimal BASH-like line editing is supported.  For the first word, TAB
       lists possible command completions.  Anywhere else TAB lists the possible
       completions of a device/filename. ]
    
    grub> find /boot/grub/stage1
     (hd0,0)
    
    grub> root (hd0,0)
     Filesystem type is ext2fs, partition type 0x83
    
    grub> setup (hd0)
     Checking if "/boot/grub/stage1" exists... yes
     Checking if "/boot/grub/stage2" exists... yes
     Checking if "/boot/grub/e2fs_stage1_5" exists... yes
     Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  18 sectors are embedded.
    succeeded
     Running "install /boot/grub/stage1 (hd0) (hd0)1+18 p (hd0,0)/boot/grub/stage2
    /boot/grub/menu.lst"... succeeded
    Done.
    
    grub> quit 
    
    mepis1:/home/demo# reboot
    It still does the same thing. I do find it strange that it says I have ext2fs, when I actually have ext3fs.

  8. #8
    Just Joined!
    Join Date
    Dec 2009
    Location
    New Mexico
    Posts
    5
    As weird as this sounds, because of my desperation to get a working OS, I decided to install Debian (since MEPIS is based on it). Though I could never get the Debian LiveCD to boot, I had better luck with the installation CD.

    This time GRUB loaded without problems, but then the graphic installation hanged after the initial reboot. So then I booted again from the installation CD and reinstalled again this time using the text installer and everything worked without any problems.

    I guess the moral of the story is just because the Live CD fails to boot it doesn't mean that the installation will also fail (unless it is the same CD). I did check all the MD5 signatures for all the Live CDs I tried and they checked out, but still they wouldn't work except for MEPIS Live.

    I am now happily running Lenny on my desktop and it's great. Thank you so much for all your help.

  9. #9
    Just Joined! gnuuser's Avatar
    Join Date
    Nov 2009
    Location
    northwestern Pa, usa
    Posts
    69
    I have found on some re installations of grub you will get error messages
    I've found this frequently with ubuntu and mepis and I'm sure there are more!
    Ive found that if you wipe the drive with d-ban and reinstall grub will load ok
    Im sure there are other ways around this problem!
    but I usually don't have a lot of time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •