Find the answer to your Linux question:
Results 1 to 7 of 7
i was trying to install yum , it successfully installed but when i run yum it said the following >>>> Code: -bash: /usr/bin/yum: /usr/bin/python: bad interpreter: No such file or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    4

    Yum install error


    i was trying to install yum , it successfully installed but when i run yum it said the following >>>>


    Code:
    -bash: /usr/bin/yum: /usr/bin/python: bad interpreter: No such file or directory

    but i have python 2.5 installed


    Code:
    Python 2.5 (r25:51908, Feb  2 2010, 20:13:22)
    [GCC 4.1.2] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>>
    is there anyone could help me for this problem ...


    Thank you in advance

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    What are you trying to install yum on and how did you install it?
    What distro are you using?

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    is it looking in the right location for python? does the file actually reside in /usr/bin ?

    Code:
    which python
    if not create a sym link to that location

  4. #4
    Just Joined!
    Join Date
    Sep 2009
    Posts
    4

    Re- Yum install error

    Sorry for late reply ,my distro is backtrack3 ,i finally edited the yum file location from /usr/bin/ to /usr/bin/python2.5 and it works now ,but again i got one error telling




    Code:
    bt ~ # yum
    Could not find platform independent libraries <prefix>
    Could not find platform dependent libraries <exec_prefix>
    Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
    'import site' failed; use -v for traceback
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:
    
       No module named yum
    
    Please install a package which provides this module, or
    verify that the module is installed correctly.
    
    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.5.1 (r251:54863, May  4 2007, 16:52:23)
    [GCC 4.1.2]

  5. #5
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    backtrack? i believe that is like slax. not sure if they even use yum to do updating or not. maybe you should try this:

    Backtrack 3 -- how do I update it? - Topic Powered by Social Strata

  6. #6
    Just Joined!
    Join Date
    Sep 2009
    Posts
    4
    i will try to do that and let you know ,

  7. #7
    Just Joined!
    Join Date
    Sep 2009
    Posts
    4
    i finally install swaret now ,was trying to install pidgin 2.6

    bcoz i removed the old version .. ,i did (--upgrade -a )with swaret for the packages , and it updated all the packages from the slackware ftp server

    but i cud not figure out the how to install the pidgin latest version wit swaret .

    i tried swaret --install pidgin -a ,not working yet






    Code:
    bt swaret # swaret --install pidgin -a
    swaret 1.6.3-2
    
    Listing available Packages matching Keyword: pidgin...
    
    No available Packages found matching Keyword: pidgin!


    can u help me please ..

    Thanks in advance..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •